It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I know that not everyone has had this issue with Hard Reset Redux, but I encountered a problem (in March 2018) with being stuck in a loop of trying to create a profile and it being denied. After searching for a solution, I found that there were others who had this same issue, but no one had received an answer that worked.
After poking around, I found something that worked for me so I thought that I'd put this out there for anyone who encounters this issue.

How I got it to work was to:
1) Go to "My Documents"
2) Create a new folder called "Hard Reset Redux"
3) Open that folder and create a new folder called "profiles"
4) Open that folder and create a new folder named "x" (with x being whatever you want your profile name to be; "Hunter", "Ace", "Joey", etc.)
5) Launch the game

This fixed the endless loop of not being able to create a profile (as one was now created manually) and I was then able to reach the main menu. I won't guarantee that it will help everyone, but here's hoping that it helps someone!