It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Create a shortcut of Grip.exe (in the base directory) or Grip-Win64-Shipping.exe (located in GRIP\Grip\Binaries\Win64), go into the shortcut's properties, and add the parameter


at the end of the target's path (including a blank after .exe/before -culture...).

Replace xx_YY with one of the following:

de_DE (German)
es_ES (Spanish
fr_FR (French)
it_IT (Italian)
ja_JP (Japanese)
ko_KR (Korean)
pl_PL (Polish)
ru_RU (Russian)
zh_CN (Chinese)

for the desired language.

Apply, close properties, start from the shortcut, and voilà, the game should "speak" the language it has been set to via the parameter.
Post edited June 19, 2021 by Swedrami