It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Just reporting FYI - when I first get to the petrified forest and tried to get back into the car after backing into the sign, the game hung. Music and sound effects (Manny walking) continue, but controls are all unresponsive and had to kill it from task manager.
No posts in this topic were marked as the solution yet. If you can help, add your reply
I had a similar issue in the tree maze. After getting out of the Bone Wagon and planting the signpost very near to the end of the car, I wanted to pick it back up but "used" the car instead. Manny then tried to enter the car but could not get around it, proceeding to try and walk through it (no clipping, he just got stuck). All I could do now, was switch between the original and remastered models/textures (via backspace) and I also had to kill the process to quit the game.

It would be nice if there was something like a timeout to the "enter the car" script, after which the actor is reset, if that is applicable.
Post edited January 28, 2015 by oriberu
I'm still having problems on this screen. I can't get back in the car. Manny just walks at it, around it, but never gets in. Sometimes he teleports to another screen (with the LSA tunnel exit and view of the city). I've tried to get in the car from every direction and he just walks at it.

This breaks the game. There's no way to continue.
Post edited January 29, 2015 by bheimbaugh
Double dittos on this problem. Running OS X 10.10.2 on a late 2013 rMBP with nVidia GT750 and 2GB of video RAM
I've posted about this in another post. Had the same issue of Manny walking into the car without climbing on or teleporting back to the 'entrance' of the forest.

Simply put,
You don't need to get back in Glottis's car. Just run around to the different areas on foot to complete them [the puzzles] and you'll be on your way to Rubicava once you've completed the bone beaver puzzle and opened the gate.
Post edited February 01, 2015 by Armaron