It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello Grim Dawn Community/ Developers,
I recently bought GD, But it won´t start. I just get a black screen, Loading symbol on the cursor and after that GD does not response, so I have to shut it down via Task Manager. I have tried everything i found on forums for troubleshooting:
-Reinstall, Repair function, delete "options" file
-added /d3d9 in startoptions of the game
-deactivated anti-virus software / added GD to the exception list
-installed /reinstalled .net framework, visual studio c++,
-start as admin
-disable the nvidea gforce experience overlay
-changed the solution of the desktop (bigger icons 150% to 100%)

Nothing worked. GD still wont start and doesnt response

A friend of mine mentioned that there could be a problem with nvdiea card (I have a RTX 2070).

My PC- Specs

Win 7 Ultimate SP1
CPU: Intel I7-6700K 4.00GHz
GPU: MSI Armor RTX 2070 8 GB

Do you know something about it? Or got other solution approches?

Many thanks in advance
No posts in this topic were marked as the solution yet. If you can help, add your reply
See if anything here helps
As you were Soldier!

My two cents is, your computer specs, winblows and card are giving you trouble. How to fix it is another question... gl.