It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Edit: Solved with 3/27/2019 patch!

I went to fire up Grim Dawn………….and it’s broken on both my machines. Black screen with spinning windows cursor. Task manager takes forever to stop it. I found a solution, and thought I would share in case anyone else is having the same problem. Hope this helps.

The GOG shortcut points to the executable here.

C:\YourGOGfolder\Grim Dawn\x64
I’ve tried every fix on the internet, and this won’t launch on either of my rigs.

I was able to launch the game from this executable.

C:\YourGOGfolder\Grim Dawn\Grim Dawn.exe

If GD launches your good, if not do this as well.

Turn off UnPn in your game settings text.

C:\Users\YOU\Documents\My Games\Grim Dawn\Settings

Update the following line to.

UPnPEnable = false

After doing both I was able to launch the game, and play on LAN. On a side note to Crate. Being the only game out of 200 in my library that gives me problems every time I try to launch it isn’t a good look if you want to keep selling me DLC

: )
Post edited March 27, 2019 by UltraComboTV
Maybe you have a bad windows, or bad usb connected to your machines.
Just because you have crashes each time you try to launch it doesn't mean Crate did a bad job with this game. There's a lot of stuff going on in a computer those days and plenty of opportunities for something to crash. Some possible issues are completely external to the game and the developers can't do anything about those.

I'm not saying GD is perfect but it have always ran smoothly on my machine (with reasonable graphical settings) and it has an excellent alt-tab support. While plenty of games i've played just freeze and must be killed from task manager if you just attempt to alt-tab, i can put my computer to hybernation with GD alt-tabbed and resume my game the next day without any issues. If i were following your reasoning Crate are the best developpers in a world of crappy games. If you have issues that no fix found on the net can solve it's probably something pretty specific to your machine and thus something Crate can't fix easily unfortunately.

Regarding your fix, are you able to launch GD from the shortcut after launching it once from the executable in the main folder or do you have to always launch the executable in C:\YourGOGfolder\Grim Dawn\ (or maybe did you change the shortcut to point at this executable)?

I ask this because the executables in C:\YourGOGfolder\Grim Dawn\ and C:\YourGOGfolder\Grim Dawn\x64\ are totally different applications. The one in x64 is the new (from patch 1.1) 64 bit executable while the other one is the old 32 bit executable. If you can use the 32 bit executable but not the 64 bit one it might indicate your system has troubles with 64 bit. Are your machines or OS old?

It's also entirely possible that there are bugs with the x64 executable as it's pretty new (1.1 is what, a week old maybe). A bunch of issues have been fixed in hotfix 1.1.1 (might not be available on GoG yet, at least it wasn't yesterday when i checked) and from what i understood there's another one coming soon. As you can see they are busy trying to fix issues but they can't guess what's wrong simply from "black screen with spinning cursor".
GD has had issues for me in the past. The repair tool usually fixed them. Sometimes I was able to just re install it, and it would work fine. I have a lot of games on GOG, and Steam, no issues elsewhere. I tried both manually installing it, as well as letting galaxy do it. No change. There is some problem with the x64 executable and my hardware. I’m using the R9-390 on one rig, and the RX-580 on the other machine. I’ll try the x64 executable on the next update, at this point I’m just happy I can play.
avatar
UltraComboTV: I went to fire up Grim Dawn………….and it’s broken on both my machines. Black screen with spinning windows cursor. Task manager takes forever to stop it. I found a solution, and thought I would share in case anyone else is having the same problem. Hope this helps.

The GOG shortcut points to the executable here.

C:\YourGOGfolder\Grim Dawn\x64
I’ve tried every fix on the internet, and this won’t launch on either of my rigs.

I was able to launch the game from this executable.

C:\YourGOGfolder\Grim Dawn\Grim Dawn.exe

If GD launches your good, if not do this as well.

Turn off UnPn in your game settings text.

C:\Users\YOU\Documents\My Games\Grim Dawn\Settings

Update the following line to.

UPnPEnable = false

After doing both I was able to launch the game, and play on LAN. On a side note to Crate. Being the only game out of 200 in my library that gives me problems every time I try to launch it isn’t a good look if you want to keep selling me DLC

: )
Hi UltraComboTV.

-Could you post the specifications of your LAN connected PCs here?
-Are your GPU drivers and both of the OSs your LAN connected PCs run updated?
-Are you running the game through the GOG Galaxy application? Do both PCs run the same version of the application and the game?
(The installation files might be corrupted and you would need to redownload them or use the GOG Galaxy application to verify the game files, after it is installed).
-Are you using a 3rd party USB/ PCI connected Ethernet card?
-Are you using a cable or a wireless adapter to create a LAN network? Is it configured via the standard network manager Windows provide? Does the game have a firewall exception on both of your LAN connected PCs?
(There are ways to create a VLAN via the Internet using software like "Hamachi", instead of a cable or WLAN).
-What software or hardware component(s) do both of your PCs have in common?

Cheers.
Post edited March 27, 2019 by Fate-is-one-edge
Well Crate must have been aware, todays patch just fixed my problem. Thanks for the feedback. On to the new expansion cheers!
I was able to get the game to work by re-installing DirectX ...