It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi there!

I can't play the game at all. When I start it it says: "Cannot initialize Direct3D device". I do have a config folder which seems to solve the problem for some users but not for me. I have the latest patch 1.7.

What can I do? Please help!

Thanks a lot!
No posts in this topic were marked as the solution yet. If you can help, add your reply
This is a late reply but I only now got the game. I am posting the solution I found in case others have the same problem as I and the OP:

The problem is the Anti Aliasing (MSAA), so one way of fixing it is to choose the "None" option and not use AA. But if you're like me and enjoy playing with AA then you have to go to your graphic card options (I have Nvidia so I can only tell how to do it on these kind of cards):

1- Open the Nvidia Control Panel
2- On the "Program Settings" tab choose "Grandia II Anniversary Edition" on the"Select a program to customize" (or do the next step on the "Global Settings" Tab and it will be applied to all programs on your computer)
3- Go on the Settings panel and change the setting "Antialiasing - Mode" and on the drop down menu
4- Choose the "Enhance the application setting"
5- On the "Antialising - Setting" option change it to whatever value you want it to run (I changed it to 8x just like in the maximum value we can choose in game settings).

That fixed it for me, hope this helps anyone in the future.
Post edited June 13, 2016 by Risewild