}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
high rated
Hi,

Recently I installed G2: Gold. The game was running beautifully until I got outside Xardas' tower. Frames tanked to 20-30 range. Looked around for a solution on steam forums, here on gog, wog, etc. Most people were reporting issues with nVIDIA cards (that was supposedly fixed with newer drivers) but I have an AMD 5870.

I downloaded an application called GPU-Z that shows how the card is performing. I ran it in the background while playing Gothic 2 and noticed that the core clock and memory clock were running on 2D settings. Newer cards downclock themselves if no 3D application is running to save power.

It seems like AMD Catalyst does not consider G2 to be a 3D application. So I made a profile for G2 in Catalyst - turned on AA and AF (both 2x). Core and memory clocks run at 100% while running G2, so I get smooth 60 FPS outdoors as well.

So far no issues after playing for 5 hours. Sometimes when pressing Esc the world will get a litle darker but can be easily fixed by pressing Esc again (happens for the first time whenever playing G2).

TL;DR: Turn on some small graphical goodies in Catalyst Control Center under Gaming tab -> 3D Application Settings -> Add profile for Gothic 2
Attachments:
capture.png (123 Kb)
My god! It works!

I tried disabling AA to see if AF alone would work, and it did not. I'm definitely confused by this, but for the first time on this computer Gothic 2 feels smooth and works fantastically. Thanks
Stickied for graet justice! :D
avatar
Norgur8: Hi,

Recently I installed G2: Gold. The game was running beautifully until I got outside Xardas' tower. Frames tanked to 20-30 range. Looked around for a solution on steam forums, here on gog, wog, etc. Most people were reporting issues with nVIDIA cards (that was supposedly fixed with newer drivers) but I have an AMD 5870.

I downloaded an application called GPU-Z that shows how the card is performing. I ran it in the background while playing Gothic 2 and noticed that the core clock and memory clock were running on 2D settings. Newer cards downclock themselves if no 3D application is running to save power.

It seems like AMD Catalyst does not consider G2 to be a 3D application. So I made a profile for G2 in Catalyst - turned on AA and AF (both 2x). Core and memory clocks run at 100% while running G2, so I get smooth 60 FPS outdoors as well.

So far no issues after playing for 5 hours. Sometimes when pressing Esc the world will get a litle darker but can be easily fixed by pressing Esc again (happens for the first time whenever playing G2).

TL;DR: Turn on some small graphical goodies in Catalyst Control Center under Gaming tab -> 3D Application Settings -> Add profile for Gothic 2
See here:

http://www.gog.com/support/gothic_2_gold_edition/workaround_for_low_frameratestuttering_on_ati_cards

Just wanted to say thanks for finding out how to work out this issue :D.
Post edited February 25, 2013 by JudasIscariot
avatar
JudasIscariot: See here:

http://www.gog.com/support/gothic_2_gold_edition/workaround_for_low_frameratestuttering_on_ati_cards

Just wanted to say thanks for finding out how to work out this issue :D.
Just as a note, you might want to specify "AMD/ATI" (or the like) since the ATI name hasn't actually been used for a couple of years now (everything since then uses the AMD name).
avatar
JudasIscariot: See here:

http://www.gog.com/support/gothic_2_gold_edition/workaround_for_low_frameratestuttering_on_ati_cards

Just wanted to say thanks for finding out how to work out this issue :D.
avatar
Arkose: Just as a note, you might want to specify "AMD/ATI" (or the like) since the ATI name hasn't actually been used for a couple of years now (everything since then uses the AMD name).
Thanks, I'll pass that on to our Support team :D.
Hey guys. i haveve an nvidea gtx570, 8gigs of RAM and an intel i5 3.3ghz and I'm having the exact same problems. I have tried the method you used for the ATI card, setting a Gothic 2 profile with AA and AF jacked up, still the same...

Has anyone found a universal work around for this game? It's driving me nutts, as soon as I enter the environment it just drops down to 20fps regardless of any graphical setting. Gothic 1 and 3 run completely flawless.
Post edited March 24, 2013 by Junmarko
Unfortunately this can't be done in xp
For XP users, this worked for me using AMD Catalyst as well. The main difference is that you can't use Profiles. Solution? Just go to the 3D menu and set the setting manually. It'll apply to all your applications, so if it messes with other things just disable those changes when you quit. I cranked it up to maximum enhancement, and it worked perfectly. I have yet to get to back the city, where my biggest performance issues occured, but it's running silky smooth so far. I hope this helps.
Another solution that might work is RadeonPro (the tool, not the graphics card). But for this you have to enable OverDrive for the specific game (you can leave the clock as it is, if you dont want to overclock you graphics card), then you will be able to tick the Always use highest performance clocks while gaming checkbox, so that your graphics card will run in 3D clock while the game is running.
Post edited April 21, 2014 by ThomasD313
For me (with XP and my 5770 card) the outdoor scenes in Gothic 2 run okay at 1920x1200 with 2xAA and AF; however I have noticed that they're very sluggish for the first few seconds, almost as though the textures or something are being loaded into memory. I've tinkered with my Gothic.ini file quite a bit though.

For example, when I first climb up to the top of Xardas's tower and look outside, the framerate drops down really low, but only for about 10 seconds. Then it returns to more-or-less normal. I have the view ranges set to 240%, too.

Nothing to complain about, really. I'm just sharing my experiences.

UPDATE: The new Catalyst Control Center 14-4 help too. It seems considerably faster to me.
Post edited May 02, 2014 by UniversalWolf
Strange. Didn't work for me, for some reason. I tried turn on AA and AF in Gothic.ini and/or in CCC (with different versions as well 14.4 and 14.7RC3 as well), but to no avail. I guess it's some kind of Gothic Universe law - there always will be outdoor FPS drop.

PS. Could you tell which version you were using with that trick? Thanks in advance.
Have you forced AA or AF via your graphics driver settings or any tools?
Hello. I'll refresh this topic. I have ATI FireGL card and cant find anyway how to do the tips described here. Are there even possible to use with my Graphic card? Can someone post instruction how to exectly check if my card treats gothic 2 as a 2d application?

And another question: Anyone knows a video card that is known FOR SURE to work good planwith Gothic and older games generally? I am planning on upgrading my card and i dont need any high-end stuf cause i play mostly older games.
Post edited September 25, 2014 by ANC111
I just finished playing Gothic 1, and decided to hop onto Gothic 2. The problem is that I get some stutter in the starting area, right there where you can do your first quests in a barn with sheep.

I read this sticky but no matter what I try, I can't seem to enable anisotropic filtering and anti-aliasing on Gothic 2. I'm using the gothic2_fix-2.6.0.0-rev2.exe, gothic2_playerkit-2.6f, & the g2notr-systempack-1.1exe. The first one is needed to play mods, and the system pack requires the player kit to be installed.

It's driving me crazy. My specs are in the attached image. No anti-aliasing is visible, and I can easily tell anisotropic filtering doesn't work either because the road leading to the city is incredibly blurry a few steps ahead of me.
Attachments:
Post edited June 25, 2016 by Lucas9