It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Just in case this will keep others from pulling their hair out...

Grabbed the game from GOG today, had a devil of a time getting it to behave. Driver update, fiddled with the settings, etc. Basically had a frame rate of 2 in the Ghoul Room.

Turns out the solution (for myself at least) was simply to "Run as Administrator". Now the game runs almost too fast. The enhanced cursor certainly spins too quickly. Makes me a bit queasy. The mortals don't move to fast, I think, but will have to see.

Hmm... I wonder what modifying the process priority will do then... This can be done in the windows task manager.
Post edited June 12, 2011 by b0kater
I'm playing under windows 7 with no problems at all. I wonder what's up.