It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm having a problem with Ghost Master. The graphics are "choppy" and it looks like a problem with the refresh rate. The problem is present everywhere including the menu and makes the game unplayable.
I've tried updating my graphics card drivers and direct x drivers to no avail.
My graphics card is a "VIA S3G unichrome pro igp"
Any ideas?
This question / problem has been solved by ethanpdimage
I'd probably try turning down some of the graphic settings like antialiasing in case your graphics card doesn't like it.
Also, I know with VIA it can sometimes be a little picky about getting the "right" drivers. is where you can get the most current drivers. Here's the links:
XP 32-bit:
XP 64-bit:
Vista 32-bit:
Vista 64-bit:
EDIT: For the above websites, you also have to know the chipset of your motherboard, like the P4M900 for example.
Tried and failed :-(
Not only that, but when I tried updating the drivers, the pc started giving me problems with running normal videos as well. The same flickering screen that was happening with the game. Ended up having to roll back the drivers.
Found this on the developer's website:
"Users of certain graphics cards may experience minor problems with the mouse pointer. In most cases these problems can be avoided by selecting to use a basic in-game mouse pointer. To use the basic in-game mouse pointer, follow these steps:
1. Via the main menu or pause menu, select "Options"
2. Using the options category tabs at the top of the screen, navigate to the
display section by clicking on "Display"
3. Disable the "Enhanced Cursor" (so that no tick appears in the box)"
Unfortunately, I also found this on their website, too:
"The following chipsets/graphics cards are NOT supported:
Rage Fury Maxx
Matrox Series of Graphics Cards
Sis Series of Graphics Cards
3Dfx Voodoo Series
S3 Savage Series of Graphics Cards"
The last one in that list is what the VIA chipsets use. And if the mouse fix above doesn't work, then probably the only thing you can do is go out and get a GeForce or ATI card to put in your system. At least then, you won't have any compatibility problems like this again since every PC game these days is designed to fully support those two cards.
Thanks a lot for all your help. I had already tried the mouse pointer but failed as well. I'm afraid I have to get another gfx card.
Take care.
I've just installed Ghostmaster on Win XP/ATI Radeon 8450/Catalyst Drivers 8.12 and after it loads and displays a couple of intro screens it automatically changes the refresh rate higher than the maximum 75Hz my LCD monitor will allow, and I'm left with a black screen and "out of range" message" on my monitor.
To confirm that the refresh rate was the culprit, I tried running the game hooked up to my Sony LCD TV which has a maximum refresh rate of 120Hz, and the game works fine on that, which indicates that Ghost Master is forcing a refresh rate higher than 75Hz.
Unfortunately, forcing a refresh rate override in the ATI control panel didn't fix the problem so I found and ran a program called RefreshForce and then clicked the 'apply' button and now Ghost Master will run correctly at any resolution with the refresh rate at 60Hz.
If anyone else is having the same problem, if the refresh rate override option in your gfx card drivers doesn't fix the problem, then give RefreshForce a go.
Post edited December 31, 2008 by Refrenz