It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Googled this, found many comments .. Sadly, none gave a resolution.

Thinking it would help, I re down loaded... Galaxy, I still get the "not connected".... but now I can't load "owned games"... click on, "connect now"... no change. Any ideas??

Galaxy settings of no help.

GOG customer service is taking months to respond.... Hate, annoying GALAXY.... but, at least until today, it did work.

Anyone else started to have this issue.... thanks
Double-check that GOG Galaxy has access through your firewall. There are multiple executables spread across C:\Program Files (x86)\GOG Galaxy and C:\ProgramData\\Galaxy

If possible, try switching to a different Internet connection. For example, use your phone as a mobile hotspot and connect via Wi-Fi.

Some users have reported GOG Galaxy showed no games, then after a few days, it fixed itself. There may be some problem that only affects the GOG servers in your area.

As for GOG support, you can try adding a reply to your ticket. A polite note along the lines of Excuse me, I've been waiting (this long) and I could really use some help with this problem has been known to result in a response.
I faced a similar issue (I couldn't install any game due to connectivity issues). I was able to fix it by:

1. Completely close GoG Galaxy.
2. Disable IPv6 (search how to disable IPv6 in your OS online).
3. Open GoG Galaxy.


I figured this out by examining C:\ProgramData\\Galaxy\logs\GalaxyClient.log which had the following error:

> [Error][ (0)] [TID 6132][galaxy_client]: An error occurred, Other, while performing request (requestId: 238) for URL '{redacted}' after 10003 ms. Exception: Timeout (connect timed out: [2001:1900:2318:1f03::2]:443), code=0
> [Error][ (0)] [TID 11820][galaxy_client]: Unable to get response for request url {redacted}. Response code Uninitialized.

You can see that the IP address shown there is IPv6, disabling it on my machine did the trick.

Maybe this works for your problem too?
Post edited June 03, 2022 by marcogrcr