It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
If you run as a normal user in Windows, not an admin, any game installation that uses the "scriptinterpreter.exe" tool will fail, every time. You'll be prompted to enter the admin credentials, and then the tool will fail. It'll happen a few times, then give up and fail the installation. This has been an issue for a long, long time as far as I can tell from a few Google searches. However, recently the issue was 'fixed' in a way that made things much worse. Before the installation would fail, but the game would show as installed and you could manually run the DX redist installer. Now, the installation fails and the game is permanently inaccessible from within GOG and worse, it keeps retrying over and over with a very annoying admin request each time.

The workaround I've found that sometimes, but not always, works, is to move the game folder out. You can then remove the game from GOG. At this point move the game folder back, and scan the directory. If you're really lucky it won't require the setup process anymore and the game will work fine. If the game doesn't run, manually running the redist stuff will fix it. But if Galaxy decides that it needs to run the setup again you're dooooomed.

GalaxyClientService.log

2021-08-20 09:48:30.032 [Notice][#1 (1)] [TID 10128][galaxy_service]: The sender was recognized as a trusted client (GalaxyClient).
2021-08-20 09:48:30.032 [Information][#1 (1)] [TID 10128][galaxy_service]: Received LaunchElevatedRequest 2779731949
2021-08-20 09:48:30.033 [Information][#1 (1)] [TID 10128][galaxy_service]: RunUserProcess will use current user impersonation for elevated process: "C:\Program Files (x86)\GOG Galaxy\Dependencies\__redist\ISI\scriptinterpreter.exe" /VERYSILENT /DIR="H:\GOG Games\Tomb Raider" /Language="English" /LANG="English" /lang-code="en-US" /ProductId="1724969043" /galaxyclient /buildId="54388455997567214" /versionName="1.0" /nodesktopshorctut /nodesktopshortcut /supportDir=C:\ProgramData\GOG.com\Galaxy\support\1724969043
2021-08-20 09:48:30.034 [Information][#1 (1)] [TID 10128][galaxy_service]: Default working dir: C:\Program Files (x86)\GOG Galaxy\Dependencies\__redist\ISI\
2021-08-20 09:48:30.038 [Warning][#1 (1)] [TID 10128][galaxy_service]: Waiting for process initialization failed. Return code: 4294967295.
2021-08-20 09:48:30.038 [Warning][#1 (1)] [TID 10128][galaxy_service]: Waiting for process initialization failed for C:\Program Files (x86)\GOG Galaxy\Dependencies\__redist\ISI\scriptinterpreter.exe.
2021-08-20 09:48:30.038 [Information][#1 (1)] [TID 10128][galaxy_service]: Created elevated process (id: 28044) as user. Process path: C:\Program Files (x86)\GOG Galaxy\Dependencies\__redist\ISI\scriptinterpreter.exe, command line "C:\Program Files (x86)\GOG Galaxy\Dependencies\__redist\ISI\scriptinterpreter.exe" /VERYSILENT /DIR="H:\GOG Games\Tomb Raider" /Language="English" /LANG="English" /lang-code="en-US" /ProductId="1724969043" /galaxyclient /buildId="54388455997567214" /versionName="1.0" /nodesktopshorctut /nodesktopshortcut /supportDir=C:\ProgramData\GOG.com\Galaxy\support\1724969043 , working directory: C:\Program Files (x86)\GOG Galaxy\Dependencies
2021-08-20 09:48:30.038 [Information][#1 (1)] [TID 10128][galaxy_service]: LaunchElevatedRequest complete: 0
2021-08-20 09:48:30.038 [Information][#1 (1)] [TID 10128][galaxy_service]: Sending message of type 2 [Sequence Number: 0], rseq 2779731949, size 158 (bytes sent: 158), completed OK
2021-08-20 09:48:30.038 [Information][#1 (1)] [TID 10128][galaxy_service]: LaunchElevatedRequest response sent
2021-08-20 09:48:30.039 [Information][#1 (1)] [TID 10128][galaxy_service]: Received a message from process connected at '127.0.0.1:51848'.
2021-08-20 09:48:30.039 [Information][#1 (1)] [TID 10128][galaxy_service]: Determined sender to be 'C:\Program Files (x86)\GOG Galaxy\GalaxyClient.exe' (PID: 8920)
2021-08-20 09:48:30.039 [Notice][#1 (1)] [TID 10128][galaxy_service]: The sender was recognized as a trusted client (GalaxyClient).
2021-08-20 09:48:30.039 [Information][#1 (1)] [TID 10128][galaxy_service]: Connection closed by remote host
2021-08-20 09:48:30.040 [Information][#1 (1)] [TID 10128][galaxy_service]: ServiceConnectionHandler disconnecting
2021-08-20 09:49:00.053 [Information][#1 (1)] [TID 10128][galaxy_service]: Service inactivity timeout exceeded. Terminating.
2021-08-20 09:49:00.149 [Information][ (0)] [TID 4828][galaxy_service]: Service stopped

GalaxyClient.log
2021-08-20 09:48:30.031 [Information][SubSystem installer thread (66)] [TID 15980][galaxy_client]: Requesting service to run process: C:\Program Files (x86)\GOG Galaxy\Dependencies\__redist\ISI\scriptinterpreter.exe, with arguments: "C:\Program Files (x86)\GOG Galaxy\Dependencies\__redist\ISI\scriptinterpreter.exe" /VERYSILENT /DIR="H:\GOG Games\Tomb Raider" /Language="English" /LANG="English" /lang-code="en-US" /ProductId="1724969043" /galaxyclient /buildId="54388455997567214" /versionName="1.0" /nodesktopshorctut /nodesktopshortcut /supportDir=C:\ProgramData\GOG.com\Galaxy\support\1724969043.
2021-08-20 09:48:30.031 [Information][SubSystem installer thread (66)] [TID 15980][galaxy_client]: Starting service 'GalaxyClientService' asynchronously.
2021-08-20 09:48:30.031 [Information][SubSystem installer thread (66)] [TID 15980][galaxy_client]: Requesting service to run process
2021-08-20 09:48:30.031 [Information][SubSystem installer thread (66)] [TID 15980][galaxy_client]: Sending message of type 1 [Sequence Number: 2779731949], rseq 0, size 656 (bytes sent: 656), completed OK
2021-08-20 09:48:30.032 [Information][SubSystem installer thread (66)] [TID 15980][galaxy_client]: Request sent [Sequence Number: 2779731949], waiting for response...
2021-08-20 09:48:30.038 [Information][SubSystem installer thread (66)] [TID 15980][galaxy_client]: Sending data for run process request to service complete
2021-08-20 09:48:35.331 [Error][SubSystem installer thread (66)] [TID 15980][galaxy_client]: Failed to launch the process. Error Message: Failed performing an operation upon the process ID 28044. Which gave the exit code 1.
Specific Reason: The execution of 'C:\Program Files (x86)\GOG Galaxy\Dependencies\__redist\ISI\scriptinterpreter.exe' exited with a failure code. The exit code was expected to be Zero.
Stack Trace
16: UNK - 0x13942e7
15: UNK - 0x1394060
14: UNK - 0xee8e09
13: UNK - 0x1306e14
12: UNK - 0x13081bc
11: UNK - 0x13089ee
10: UNK - 0x1308d24
9: UNK - 0x130258a
8: UNK - 0xe42f1d
7: UNK - 0xe41a0f
6: UNK - 0x13cd438
5: UNK - 0x13d12c0
4: UNK - 0x141bb39
3: Poco::ByteOrder::fromNetwork - 0x538563d1
2: BaseThreadInitThunk - 0x75b5fa29
1: RtlGetAppContainerNamedObjectPath - 0x775b7a7e
0: RtlGetAppContainerNamedObjectPath - 0x775b7a4e
Post edited August 20, 2021 by boogleoogle