}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I get this message when I try to open Stronghold Classic in mac.: "The application X11 could not be opened. An error occurred while starting the X11 server: Failed to activate core devices." Any suggestion?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Well, as long as you can laugh about I guess it's not so bad.
sometimes, when i'm perusing these forums, i feel like a cautious driver in a sea of people who have no idea where their turn signal is.
When I read the thread title I expected something like a Stronghold fail video. Now I'm disappointed :(
avatar
real.geizterfahr: When I read the thread title I expected something like a Stronghold fail video. Now I'm disappointed :(
Huh, good point. It does sound like that. Oh well. :-(

Probably a good thing the OP recreated the question with a new title:
Stronghold Classic fails to launch on Mac
avatar
K-vest: I get this message when I try to open Stronghold Classic in mac.: "The application X11 could not be opened. An error occurred while starting the X11 server: Failed to activate core devices." Any suggestion?
See here. You need to contact support to ask to update the game wrapper.
You could also do it yourself meanwhile. While I only know how its done on Linux, the general idea is:
1) install Dosbox
2) find DOS directory inside installed game directory.
3) feed that directory to Dosbox and run the .exe
avatar
K-vest: I get this message when I try to open Stronghold Classic in mac.: "The application X11 could not be opened. An error occurred while starting the X11 server: Failed to activate core devices." Any suggestion?
avatar
Lin545: See here. You need to contact support to ask to update the game wrapper.
You could also do it yourself meanwhile. While I only know how its done on Linux, the general idea is:
1) install Dosbox
2) find DOS directory inside installed game directory.
3) feed that directory to Dosbox and run the .exe
I don't think that Stronghold is running on Dosbox though. Probably Wine?
avatar
fortune_p_dawg: i feel like a cautious diver in a sea of madness
FTFY. Take a deep breath and don't panic.
avatar
SirPrimalform: I don't think that Stronghold is running on Dosbox though. Probably Wine?
Yeah, OP probably needs newer Wine version.