It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Yeah, some more digging confirmed that the main cause is this:

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).

The other errors are caused by that .js file not being loaded because of the missing CORS header. Could be a proxy or CDN issue.
It has consistently not worked for me since yesterday afternoon, and it continues that way.

Lone_Scout: It was working for me until half an hour ago or so. Now the news section seems to be broken.
It's at times like these I feel glad that Gog didn't decide they should "revamp" their News RSS feed
It's still broken for me too. I"m running Firefox.
Still broken.
This is just GOG fixing things. They always start by making it far worse and then fixing it to a state only slightly worse than it was before.
If you have a VPN, you might try using that to access the site. As people have mentioned above, the misconfiguration that breaks the site seems to be only on certain servers.

I had good success using a US-based proxy to access the site. Most European locations receive the broken site.
I have the same problem.
It's broken on my end too. Missing profile link. News columns turn up blank.
Yes it's broken for me too. I'm not from europe so ... that must mean multiple servers must be having this problem. I tried on firefox and on galaxy ... the result was the same, just like IronArcturus posted.
Post edited October 16, 2020 by Hades™
My apologies, broken for me too now unlike some hours ago.
I wonder what Epic thinks of GOG's reliability and efficiency.
What now? Do we even have any way to contact support for this ? I mean, I don't even know.
Broken here too. My hunch is a sale is incoming.
I thought it was my cache or something. Hope it gets fixed soon!
The site front page is broken for me too.