It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi Guys,

I may have not searched extensively through forums and such, but i have a problem that I just can't get through, and no solution found during last 3 hours online helped me. Anyway:

I just re-installed "windows 10 home" system on my lenovo y50-70 today. Right after I reinstalled gog galaxy, I downloaded "knights and merchants: the peasant rebellion" and "rollercoaster tycoon: deluxe" to test if I have all I need to play some more classic games again. It turned out, that after I click "Play" button on gog galaxy, it turns gray for about 5 seconds, and back to green(nothing happens). Interestingly, I also tried "Theme hospital", and it works fine for me.

At this point I guess I might be missing some essential system stuff(like .net frameworks, VC redistributable, directx, and stuff like that), but apart from those I just mentioned, I have no idea what more might be needed. (I have downloaded most of such stuff, but am I missing anything?). I was unable to find any specifics that would help me here.

Is there any way I can find out what I need for such games to work? Those that I mentioned worked for me before, but my previous system was up and running for more than 2 years(some upgrade from win8 to win10 along the way), and I guess quite a lot have been installed along the way that I might forgot about.

Best regards,
With Windows you must update it repeatedly after installing it. Unfortunately Windows update is errr not good. You need to force it to update again and again and again until it eventually runs out of updates. Return here after that if it still does not work.
Post edited June 18, 2017 by Themken
Thanks for reply.
It does not seem to be the problem though. Windows update states that everything is up to date, and no new updates can be found.
The problem unfortunately still persists.
I guess nobody has any other suggestions?
icecold.711: I guess nobody has any other suggestions?
And if you run it without galaxy? I.e. Go to short and remove galaxy part or run the actual exe what error do you get?