It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Pouyou-pouyou: This is silly as it will be necessary to redo the same for every game affected.
This is not a solution, this is a workaround.
greeno77: A workaround is a solution imo

It's not a big deal to change the name of every game you want to play, especially if you're like me and only have one game that needs this fix. The fix takes literally like a minute to do
One game,yeah. But if you have a number then the registry fix is the way to go.
And it is reversible, though, really, the fix should not hurt anything.
Screenshots taken from Win 7 64 bits but maybe it doesn't matter if it is 32 or 64 bit ( can't verify , only have 64 bits win7)

Ja2 games work a charm after i set the compat. mode to Windows 98 /Windows Me

i also checked the Disable desktop composition and Disable display scaling on high DPI settings

and Run this program as an administrator

Maybe they don't have to be checked , but since i have admin rights i just checked them.

see: ja2_+_ja_2_ub.jpg
Post edited August 27, 2019 by gamesfreak64
Absolutely (100 % ) correct way to run old games on Windows 7: :)
Launch the game through the "Game Explorer" menu:
Start - Programs - Games - "Game Explorer" - Nolf icon in the "Game Explorer" - launch from the Administrator.
Warning !!
Previously, in the “Parameters” of “Game Explorer”, enable all options, allow auto-update of games and reboot.
Post edited February 19, 2020 by JackkyJack