It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Some of you may be aware of an issue where the GOG Downloader on XP can't connect to the server so you can login and download games. I believe that components used by the downloader and supplied through Windows Update have out of date values.

The easiest fix i know of is using the unofficial Service Pack 4 by harkaz. The current version 3.1b has all Windows XP and POSReady 2009 updates up to January 2016 and the author has said a final update will be made once POSReady 2009 support ends in 2019.

Hope this helps those that have struggled.