}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello everyone. I decided to play the second Diablo. I have a retail version of it, I think it may be a reissue since in the back cover I see more up to date requirements. I have not installed Lords of Destruction yet. Also, it is the 1.12 version and I have Win7 64bit.

Now, my problem is that there is no music in the background while I play. In the main menu everything is alright and the sound effects work properly. I don't remember clearly but I think that when I started the game, there was music. I'm still early in the game btw, just cleared the den of evil.

Tried reinstallation, didn't work.

Any ideas?

P.S. Also, there is another strange thing. When I run the game as an administrator or when I run the game from the CD, my character does not appear on the single player screen. It's like he is erased. I can only load my character when I run the game through its desktop shortcut. Not a problem, just something weird.
Post edited June 11, 2017 by Martian12
This question / problem has been solved by nadenitzaimage
For the music problem, hold CTRL and press the M key, that should enable the music.

For the saves problem, that happens because you may have installed the game on the Program Files folder, and without administrative rights the game can't save the game to that folder, so it saves it in a different location. Running the game with administrative rights allows the game to read the characters from the Program Files folder which it couldn't do before.
Another case of windows uac attack. Rule one of windows is never install anything to windows folders. I always setup c:/games and install there. Avoids all these issues.

Again, if you install things to program files you will get problems.
avatar
Ikarugamesh: For the music problem, hold CTRL and press the M key, that should enable the music.

For the saves problem, that happens because you may have installed the game on the Program Files folder, and without administrative rights the game can't save the game to that folder, so it saves it in a different location. Running the game with administrative rights allows the game to read the characters from the Program Files folder which it couldn't do before.
I tried this but it doesn't seem to work ingame. It only works in the main menu, holding ctrl and m turns off/on the sound.
Did you try checking your "Options" menu?

I know it sounds lame but most of the time when i played and there was no music somehow the the sound slider for the Music was set to off (left side).

Press Esc, go to Options, Sound Options and see if the Music slider is off.
avatar
nadenitza: Did you try checking your "Options" menu?

I know it sounds lame but most of the time when i played and there was no music somehow the the sound slider for the Music was set to off (left side).

Press Esc, go to Options, Sound Options and see if the Music slider is off.
I just tried this (nice timing!) and yes, the sound slider was all the way to the left. I don't know how this happened. I feel a bit stupid to be honest :p

Thanks everyone for the responses!