It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Unfortunate that I found too late this ultimate antrad version for Abuse game.

Would like to add to this thread that I do actually have a Twitch stream. I usually stream different games, so if you ever are interested guys I can make some gameplays of Abuse on my Twitch stream, just contact me there.

twitch.tv/pasildan

I can test either the official version and frabs or any other customized scenearios, I'm glad that there are still a few couple of people like you who enjoys this simple but really enjoyable game.

Regards.
I need help from Windows 10 users. Many people want to play the game WITHOUT music (I agree it is more atmospheric experience that way). Since I was not able to figure out how to fix volume controls, when I was testing this on my Windows XP/7 computer I could just delete the music folder and the music would not play. But it seems when you do this on Windows 10, ALL sound effects stop playing.

I need people with Windows 10 to test this:
- Download the game from moddb: https://www.moddb.com/games/abuse/downloads/abuse-sdl-09a-windows
- Start the game to see if everything is working normally (music and sound fx should play)
- Then delete or rename the music folder and start the game again to see if the music stopped playing and do other sound effects still play
- If there is no sound effects playing in the step above, try running the game again in Windows 7 or XP compatibility mode and see if sound effects will work then

Thanks
Post edited September 30, 2019 by antrad88
avatar
antrad88: I need help from Windows 10 users. Many people want to play the game WITHOUT music (I agree it is more atmospheric experience that way). Since I was not able to figure out how to fix volume controls, when I was testing this on my Windows XP/7 computer I could just delete the music folder and the music would not play. But it seems when you do this on Windows 10, ALL sound effects stop playing.

I need people with Windows 10 to test this:
- Download the game from moddb: https://www.moddb.com/games/abuse/downloads/abuse-sdl-09a-windows
- Start the game to see if everything is working normally (music and sound fx should play)
- Then delete or rename the music folder and start the game again to see if the music stopped playing and do other sound effects still play
- If there is no sound effects playing in the step above, try running the game again in Windows 7 or XP compatibility mode and see if sound effects will work then

Thanks
I downloaded the game and started it. Works fine with music and sound effects. Once I renamed the "music" folder, no mor sound effects and no music. Starting the game in compatibility mode did not change anything (I tried Windows 7 and Windows XP SP3). Hope, this helps.
avatar
john_hatcher: I downloaded the game and started it. Works fine with music and sound effects. Once I renamed the "music" folder, no mor sound effects and no music. Starting the game in compatibility mode did not change anything (I tried Windows 7 and Windows XP SP3). Hope, this helps.
Thank you very much.

I would need one more thing tested. One user on moddb said using midi files, instead of original hmi files breaks music playback, but sound effects still work. It is a weird way to fix something, but it is easiest solution for now.

I have prepared the files in the link below. Could you remove the original music folder, and put this music folder instead to confirm his ? Music should not play, but sound effects should play now.

These are original Abuse music files converted to MIDI, but with a HMI extension:
https://drive.google.com/file/d/1wLS4MkCpHYpMesdZduLZtm7TyaZ06H6R/view?usp=sharing
Post edited September 30, 2019 by antrad88
avatar
john_hatcher: I downloaded the game and started it. Works fine with music and sound effects. Once I renamed the "music" folder, no mor sound effects and no music. Starting the game in compatibility mode did not change anything (I tried Windows 7 and Windows XP SP3). Hope, this helps.
avatar
antrad88: Thank you very much.

I would need one more thing tested. One user on moddb said using midi files, instead of original hmi files breaks music playback, but sound effects still work. It is a weird way to fix something, but it is easiest solution for now.

I have prepared the files in the link below. Could you remove the original music folder, and put this music folder instead to confirm his ? Music should not play, but sound effects should play now.

These are original Abuse music files converted to MIDI, but with a HMI extension:
https://drive.google.com/file/d/1wLS4MkCpHYpMesdZduLZtm7TyaZ06H6R/view?usp=sharing
No problem.

Once I extract the rar file into the game directory, the game won't start. Last info is "engine: registering base graphics", the game window opens, stays black and closes without any message. If I remove the music folder or use the original one, game starts normally. If there is anything else I can help with, just say so.
avatar
john_hatcher: No problem.

Once I extract the rar file into the game directory, the game won't start. Last info is "engine: registering base graphics", the game window opens, stays black and closes without any message. If I remove the music folder or use the original one, game starts normally. If there is anything else I can help with, just say so.
Thanks again for your help. Actually the game crashes for me too, I forgot to check it before (I could swear I did, I probably mixed the folders). Sorry for wasting your time. I don't know how it worked for that guy. I will try contacting him again to send me his files.
Post edited October 01, 2019 by antrad88