It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Trying to keep this as *spoiler-free* as possible, but if the only answer is a *spoiler*, then go ahead and tell me.

I've joined The Awakened and Learned Pinner has granted me access to his back rooms. The deepest one has explosive box mines in it. No matter how many times I try, I die. I've tried disarming them (I have 10 in Mechanics) and it sets off a chain reaction. I've tried sending my Cryoa in to take the damage instead of me, but they are friendly toward him & don't explode. I've tried running in and then out again with a Speed Pod, in an effort to trigger them & then get out of the blast area, but they get me anyway.

What else can I try to clear the room?
If I remember correctly there was green or brown spores baton for mines somewhere else (remote detonator, there's also red spores baton but you won't get it too soon)..

They look like Living Tool but can be used around 12 times.

The typical ones are often related to crystal.

Unlock spell can help if your Mechanic skill (at least 12) isn't sufficient.
Post edited June 28, 2014 by HenitoKisou
I remember using spore batons in GF1, so knowing that they are somewhere in GF2 (without specifically telling me where) is perfect. Thank you. :-)
Just finished GF2 and found no spore batons at all. Oh well, no big deal.