It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello everyone.

So, I have tried to open the map editor and I get a screen with a bunch of white and some colored squares. I get a map overlay with outlines of squares, but that is it.
I access the map edito by clicking on manage installation, look at folder, opening the Twilight folder, Opening the Tools subfolder and clicking on the Galciv2 map editor application file.
Please advise.
No posts in this topic were marked as the solution yet. If you can help, add your reply
michaelhoggan: Please advise.
The GOG installer isn't setting all of the necessary registry entries, which causes all of the editors to not work.

I ran into the same issue with the scenario-editor. In the end, I got it working again by using my old installer from Stardock.

Sadly, I'm not that familiar with the Windows registry. So I don't know which entries you need, or where they go.