It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Usually one of the first things i do when setting up a new computer is to turn off all the IDIOT sleep modes AKA 'crash modes' That i can find... PC, CPU, graphics, monitor, HDD, all set to NEVER sleep - AKA, crash mode.
Even just sleeping the monitor is an excuse for a game to crash.

I been into computer gaming for the past 30 years and i never had a system that did not have sleep mode as a fuckup, honestly, i dont even know why they still bother with it???

However, even with all the sleeps disabled on my system, Galciv3 is still sleeping somehow? When i wake it, the game is frozen but pressing CNTRL ALT DELETE immediately unfreezes it. I am just waiting for the moment that does not work because i cannot find whatever is causing this sleep?

Does Galciv3 have its own sleep mechanism??
No posts in this topic were marked as the solution yet. If you can help, add your reply