It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So a friend and I just bought this game in the hopes of playing multiplayer. We are able to host the game and the other joins it. When we try to start it loads for a while before giving the host a peer disconnected error *see attached picture*
We've tried many types of game settings, including changing the map to tiny and having no AI players. On a side note when my friend closes the game a process remains which slows his computer down immensely until he manually kills it. He has tried uninstalling galciv3 and galaxy to fix this issue and it hasn't worked.
We have also tried using third party connection software, in this case Tunngle, which has fixed this type of problem on other games such as anno2070. Still no luck here though.
The main question is, can we do anything about this issue?
No posts in this topic were marked as the solution yet. If you can help, add your reply