It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi folks,

I'm having an issue with a friend on a 1/10 Mbit (1 up, 10 down) connection. We can play MP just fine but loading a game times out every time. My internet is 10/100 Mbit and I have no problems with latency or anything else.

SD support suggested I try loading an MP game with someone else on a "less limited (!) network". Anyone here fit that criteria? I only know one person with a GOG copy of GalCiv3, that being the above-mentioned friend I can't play with. :\

Msg/friend/whatever me if you're available. Thanks in advance!!
Ok, so nobody is interested in trying to load an existing multiplayer session? Cmon, I don't bite. :D

Past that, has anyone actually got GalCiv3 multiplayer working on GOG's servers?

I can start a new MP game just fine.

Whenever my friend tries to join a *restored session*, it puts him in the lobby, then times out after 30 seconds.

This has never worked, and as of 3.10 it still doesn't work. Stardock help has been clueless and basically ignored me as the problem is almost certainly in the GOG multiplayer API / servers.

Thinking maybe at this point I should open a ticket with GOG, at least they might care.