It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
This is my own guide by trial and error and it's far from perfect but it will stop any LAG issues with the game. Once you've done this, the game will run SMOOTHLY.

1. Install Gabriel Knight 3 to C: directory directly.

2. Google dgVoodoo, and download the latest release

3. Once you've unrared dgVoodoo2, go to the folder MS -> x86. AND 3Dfx -> x86 Copy and paste ALL the files to your Gabriel Knight 3 game directory. This is important. Copy the files, NOT the folders.

4. Open dgVoodooCpl and add a new game. Choose the C:/Gabriel Knight 3 folder and press OK

5. Go to DirectX TAB.

5. Enable "Force VSync, Fast Video Memory Access".

6. Under "GENERAL"-tab choose Windowed 4:3.

7. Click on Apply and leave the window open.

You can toggle things like antialiasing under DirectX. Also try to play around with the Graphics Settings within the game itself. You can also change resolution to your current monitor's setup but for me it caused issues so I prefer the 4:3 ratio.

If you're still having issues, go to DirectX tab again and try different graphics cards settings with different amount of Vram. Usually less is better for the game.
Post edited January 20, 2020 by HannesKakkiainen
I haven't been able to solve the full screen issue. It is possible to run the game full screen either forced from dgvoodoo or from registry settings. However, for me it causes a graphics glitch. Wherever I hover my mouse, it will cause th graphics to go "wonky" in the area I just moved my mouse in. I've tried pretty much all settings but nothing seems to solve it. I've also tried to different monitors but the issue remains. So 4:3 it is for now. Centered and windowed brings out crystal clear and beautiful graphics but the image is so small it's practically unplayable.
While there are some issues running GK3 on Windows 10, it is possible to make it playable without additional software.

It won't fix every problem, but this game is currently 20 years old and has its own native issues as it is. So unless GOG or someone else ever bothers to code engine fixes and enhancements, I am just happy to still be able to play and enjoy it.

DO NOTE that switching apps while playing does NOT seem possible. You will not be able to return to the game. At best you'll be able to force it to close with the task manager, or you will have to restart Windows because the task manager window will be inaccessible. So watch your fingers when using the Control, Alt and Shift keys, that you don't accidentally press the Windows key.

Here is a list of the issues I encountered, along with solutions (at least to those that make it unplayable):

1) Flickering graphics. Just like everybody else, I first had to deal with this issue. This is simple - within the game, disable "Incremental Rendering" in the graphic options.

2) Crashes. The game simply crashes, and quite often. I found two solutions:

a) The easiest solution is to change the "3D Driver" in the Graphic options to software. BUT this still might have the occasional crash, and of-course the visual quality and possibly performance will be impacted.

b) The best solution I found suggested that seems to work well, is to force the game to run on a single CPU core. This cannot be done with the task manager due to the reason mentioned above about switching apps, and also it is not convenient to do this every time you launch game. So here is a simple way to do this, using a simple Windows application shortcut:

- Go to the GK3 folder and find the "Launch Gabriel Knight 3" shortcut.

- Make a copy of the shortcut and change its properties as follows:

- Under the "Target" field, paste the following (without quotes of-course):
"%SystemRoot%\System32\cmd.exe /C start /high /affinity 0x1 GK3.exe"

- Do NOT change anything else within the shortcut properties. The "Start In" path must retain the game folder.

- This command tells Windows to run GK3 on the first CPU core, with high priority. (I advise not to change anything about the command unless you know what you are doing)

- Use this modified shortcut to run the game.

- Note: if you make this change in the original shortcut, I do not know how it may affect GOG Galaxy interaction with the game. Although I do use GOG Galaxy, I wasn't overly concerned with it updating play time and syncing save games. I would imagine that unless you ask GOG Galaxy to fix the installation, it won't revert the shortcut.

3) Sound cuts out during dialogue. Only one solution I found - disable "Captions" in the game options. I always prefer having captions in my games, but unfortunately in GK3 under Windows 10 it seems to have trouble syncing it. You can still play without disabling the captions and suffer through these annoying cuts. You will still hear all the dialogue.

4) Full screen graphics. Since GK3 came out long before high resolution wide screens, it is meant for 4:3 ratio screens. You can tweak the Windows registry to alternative resolutions, if you know how, but I really don't deem this necessary. For some resolutions, the game will report on launch that they are either not supported, or that you don't have enough VRAM for it (simply because it doesn't detect VRAM capacity properly on modern graphics cards and operating systems), and will revert back to 640x480. Customizing the resolution might look stretched for wide aspect ratios, and of-course the FMVs are in 640x480 resolution, regardless.

5) Animation slow-downs / Low frame rate. Unless you have a very old or very low spec'd system, or tax your PC with additional software, I suspect that nothing can be done about it. I have not tried the suggested dgVoodoo2 app, and thus cannot attest to it. Between my Antivirus software warning me about the website and the issues others report using it with GK3, I saw no reason to bother with it.

I hope this helps.
Post edited April 11, 2020 by MoreGamesForMe
Fyi, latest versions of dgvoodoo led to strange white graphics on my AMD based setup. Using v2.55.4.1 solves the problem.

I've opened a thread for this but I though this info could do no harm here.

edit : GK3 is not the only game concerned, though only with recent AMD cards, so a fix is in the making and future releases of dgvoodoo should work
Post edited April 17, 2020 by Wronschien
More Games for Me fixed it for me too. The shortcut and disabling the Incremental Rendering option in game were all I needed. In fact the game worked immediately on launch, but occasional crashes were fixed by the single core change, graphics glitches by the other. Thanks mate. Windows 10, Nvidia 2080 latest drivers.
Post edited December 08, 2020 by yiasemi