It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello, I'm playing GK3 on Windows 7, and I just encountered the 'unknown fatal exception' error during Gabriel's first dream on Day 2. I see it's a common problem, and from what I understand there are no fix as of yet for my OS (or are there?). Anyway, I'm wondering if this is a persistent problem throughout the rest of the game. Are all of these .bik cutscenes going to crash like this? I realize I can watch the videos with the Rad Game Tools player. I'm fine with doing that for this video, if it is indeed my only option, but I really don't feel like dealing with this everytime a cutscene pops up. Thanks!
Just to re-emphasize, what I'd really like to know is if this crash is going to occur with every .bik cutscene in the game or if it's only the Day 2 dream. The intro runs just fine. Thanks.
Post edited February 10, 2011 by asphalthooligan
Try running the program in a different compatibillity mode. The game had a knack for crashing at that exact point if your computer wasn't up to speed back in the days, so a different compatibility might solve it.
Post edited February 24, 2011 by Minya
I had the same crash at the end of Day 2 where the dream cutscene plays.

OK, I'm not sure which one got it to work but I downloaded and installed The RAD Video Tools
and copied the binkw32.dll to Local Disk (C:) / Windows / System32 and it worked.

Hope this helps someone.


EDIT: My system is Windows 7 Ultimate 64bit, nVidia graphics card.

EDIT 2: It seems that that cutscene can still crash so try a few times if it crashes. For me it worked 4 out of 5 times. Strange stuff...
Post edited March 25, 2011 by Chudomix
Change the game's resolution back to 640x480 - that should fix the problem.
I had the exact same thing - .bik errors - whenever a video cinematic came up (I had changed the resolution to 1024x768).
When I changed the resolution back to the default all cinematics played fine.
Post edited May 03, 2011 by elventrelis