It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello all,

I can't run GK2.

Each time I launch the game, Dosbox start, goes to fullscreen, gives a line about mounting C-drive, goes to a black screen and then crashes.

The error message displayed= 'Dosbox Dos Emulator is not working anymore'.

It is not Dosbox itself, I have used it with different games without any problem at all.

I have tried running with all different modes from the 'Graphic mode setup'. This does not make any difference at all.

Does anyone know how to solve this?

Thank you.
This question / problem has been solved by Namurimage
Are you using the shortcut the installer placed on your desktop to launch the game ?
Yes, I do.
You could try to reinstall the game to see if that fixes it.

What OS are you using ?

Are you installing the game + the bundled dosbox ?
I did reinstall it (already several times) but to no avail.

I am using Windows Vista and I have installed from the setup_gabriel_knght_2-file each time. The installer works just fine.
Maybe it's a permissions issue.

Right click the game shortcut, click on properties, switch to the compatibility tab and tick the 'run as Admin' checkbox. After that go to GK2 start menu folder, right click the 'Graphic Mode Setup' icon, click on properties and do the same thing as above.

Or you could try to reinstall the game to a location outside Program Files, something like C:\Games for example. You can install to a location other than the default one by clicking the 'options' button on the installer.

If none of that works works i guess you could also try to edit the dosboxGK2.config file to see if the game boots in windowed mode. You'd have to change the line

fullscreen=true

to

fullscreen=false
Post edited May 31, 2011 by jurijchrul
I'm having a similar problem. The instillation went fine but I click on the short cut and nothing happens or dosbox pops up for just a second. My Pc (which runs XP) has the recommended specs but it doesn't work.

I've tried all of your suggestions except for running it in a window
Hello Namur,

Changing fullscreen to false did the trick. It does seem to be a graphic incompatibility. I fiddled around with my screen & monitor setting but I can't seem to find what causes it.

Anyway - it is working fine on no-fullscreen mode.

Thank you for the help.
You're welcome, i'm glad you can at least play the game in in windowed mode.

I don't know what could be keeping it from working in fullscreen. Maybe look into your graphics card scaling options. You could also try to update the dosbox version that came with the installer to see if it makes a difference.
Got it working! Just needed to run it in window mode. Thanks for the help
You're welcome.

I wish i knew why it's not booting in fullscreen for you guys but i'm affraid i don't. In any case i'm glad you can run it windowed at least.