It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I got a problem with GK3. The game launches fine, but mouse doesn't work, and when playing in high-res (by modifying the registry entries) the game is unplayable: mouse still doesn't work and the screen is reduced to an extremely little, confused screen at the left top of the monitor. The game never had such problems with my old PC!

Running on Windows 7 64-bit with Service Pack 1 installed.

Video card is an Nvidia GTX 750ti (Asus OC version).
Post edited March 25, 2015 by MrFreeman
avatar
MrFreeman: I got a problem with GK3. The game launches fine, but mouse doesn't work, and when playing in high-res (by modifying the registry entries) the game is unplayable: mouse still doesn't work and the screen is reduced to an extremely little, confused screen at the left top of the monitor. The game never had such problems with my old PC!

Running on Windows 7 64-bit with Service Pack 1 installed.

Video card is an Nvidia GTX 750ti (Asus OC version).
Same Problem for me (Windows 7 64bit). Here is my solution:

Edit registry
HKEY_CURRENT_USER\Software\Sierra On-Line\Gabriel Knight 3\Engine

Change Rasterizer = guid
to
Rasterizer = software

Start the game. Mouse now work and the "confused screen at the left top of the monitor" is going away...
Change the game options through the interface (use right mouse button in the game).

My options:
-> Configuration Options
--> Graphic Options:
3D Driver: NVIDIA GeForce GTX
Resolution: 1024 x 768
Incremental Rendering = OFF
--> Advanced Graphics Options:
Texture Quality = HIGH
Lighting = HIGH
Mip Mapping = OFF
Animation Interpolation = OFF
Tri-Linear Filtering = OFF
LOD = +


EDIT:
3D settings and antialasing options of your NVIDIA graphic card (right-click on your desktop and select "NVIDIA Control Panel"). Disable all possible options (change the settings to OFF) and confim. Now apply the changes and check if this resolved the issue.
Post edited May 05, 2015 by KingCross
avatar
MrFreeman: I got a problem with GK3. The game launches fine, but mouse doesn't work, and when playing in high-res (by modifying the registry entries) the game is unplayable: mouse still doesn't work and the screen is reduced to an extremely little, confused screen at the left top of the monitor. The game never had such problems with my old PC!

Running on Windows 7 64-bit with Service Pack 1 installed.

Video card is an Nvidia GTX 750ti (Asus OC version).
avatar
KingCross: Same Problem for me (Windows 7 64bit). Here is my solution:

Edit registry
HKEY_CURRENT_USER\Software\Sierra On-Line\Gabriel Knight 3\Engine

Change Rasterizer = guid
to
Rasterizer = software

Start the game. Mouse now work and the "confused screen at the left top of the monitor" is going away...
Change the game options through the interface (use right mouse button in the game).

My options:
-> Configuration Options
--> Graphic Options:
3D Driver: NVIDIA GeForce GTX
Resolution: 1024 x 768
Incremental Rendering = OFF
--> Advanced Graphics Options:
Texture Quality = HIGH
Lighting = HIGH
Mip Mapping = OFF
Animation Interpolation = OFF
Tri-Linear Filtering = OFF
LOD = +

EDIT:
3D settings and antialasing options of your NVIDIA graphic card (right-click on your desktop and select "NVIDIA Control Panel"). Disable all possible options (change the settings to OFF) and confim. Now apply the changes and check if this resolved the issue.
Thanks for the reply, whenever i'll install back the game i'll try this options,