It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I bought Gabriel Knight today and was a little disapointed to fin a bug or two in the game. I don't know if it's something that can be easily fixed by changing a few settings in DosBox or not, but hope you can help me either way.
The mouse cursor keeps "jumping" at random times, most often when I have the menu open. I move it a little and suddenly the cursor is several inches to the right.
The sound also skips a little during dialogie. It sounds fine, but occationally a half-secon is just missing. Don't know if there's supposed to be any sound during the intro or not, but it is completely silent.
I have no experience with DosBox, so if there's anything at all to try or change in it, please assume I'm a complete moron that has trouble walking and chewing gum at the same time.
Thanks for reading this, and I hope you can help me out...
This question / problem has been solved by Namurimage
avatar
Gormash: I bought Gabriel Knight today and was a little disapointed to fin a bug or two in the game. I don't know if it's something that can be easily fixed by changing a few settings in DosBox or not, but hope you can help me either way.
The mouse cursor keeps "jumping" at random times, most often when I have the menu open. I move it a little and suddenly the cursor is several inches to the right.
The sound also skips a little during dialogie. It sounds fine, but occationally a half-secon is just missing. Don't know if there's supposed to be any sound during the intro or not, but it is completely silent.
I have no experience with DosBox, so if there's anything at all to try or change in it, please assume I'm a complete moron that has trouble walking and chewing gum at the same time.
Thanks for reading this, and I hope you can help me out...

Hi,
In the game start menu folder, there should me a graphic setup tool. Try using it to change the graphic mode. Perhaps that will improve performance.
And you should always start the game with the shortcut gog's installer placed on your desktop.
Changing it to OpenGL seemed to fix up the mouse problem.
The sound is still an issue. Will look through the other topics for an answer to that.
avatar
Gormash: Changing it to OpenGL seemed to fix up the mouse problem.

That's great.
Regarding sound, there's an ongoing discussion regarding sound issues in this thread. There are a couple of workarounds to minimize the 'electric' sound on voices issue in there, although i haven't tried them myself cause i still haven't installed GK.
I thought I'd note here what I discovered in case it's of use to anyone, even though this topic is old and marked solved.

I had sounds skipping in GK1 and GK2 as well as background music slowing down
when moving the mouse. First I thought that my computer wasn't powerful enough, but the CPU wasn't being maxed out at all. I think it was some sort of a synchronization issue, since changing the monitors display frequency from 60Hz to 70Hz completely fixed it.

Another thing that also completely fixed it was adding frameskip=1 to the dosbox configuration file to skip drawing every other frame. It's not very noticeable, but I still prefer the first option.

The intro music, as well as a most of the background music is playing through midi audio. If it's not audible, perhaps the subsystem isn't properly set up? I myself have an SB Live! card with a hardware wavetable synth that dosbox wanted to use, and there was no music until I loaded a soundfont.