It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I've installed FTL under VirtualBox, in both 32-bit Windows Vista and 64-bit Ubuntu Linux. In both cases, the game seems to play fine, except that the mouse pointer moves like a person on ice. When I stop moving the mouse, the pointer doesn't stop right there, it slows down and stops further on. That makes it very hard to click accurately on the small items in FTL; I have to sort of circle in on them and try to slow down before I get to what I want to click.

The mouse pointer doesn't do this in anything else in either system, and as soon as I move outside the FTL window, it acts normally. I don't have mouse trails or shadowing or any fancy mouse pointer effects turned on. Both virtual systems have two 4.0Ghz CPUs and 4GB RAM, so I don't think they're short on resources.

Has anyone else experienced this, or have a suggestion? Thank you.
avatar
aaronbaugher: Has anyone else experienced this, or have a suggestion? Thank you.
Run it native or is that too obvious?
Just install FTL under Ubuntu 16.04 inside VirtualBox and test it out.
The mouse pointer moves slow, but not to the extend as you describe.
Is it possible your hand movement is too fast and wide, and not get used to the speed?
I admit I move my hand slowly in the test run, and FTL doesn't require fast mouse movement as it can pause anytime.

However I do have some visual problem running the game.
Once 3D Acceleration is enabled, part of the drawing become transparent, and cannot tell the damage level as all icon become white, no green, orange or red.
So as the dialog window and starmap, the background is dropped and make it difficult to read.
Some kind of display overlay problem.
When 3D Acceleration is off, visual problem is gone.

PS: VM config
RAM: 2GB
CPU: 2 units (host CPU i3-4010U)
Extension Pack is installed
avatar
aaronbaugher: Has anyone else experienced this, or have a suggestion? Thank you.
avatar
Gydion: Run it native or is that too obvious?
I don't currently have a native Windows or Linux system (I'm running VirtualBox on FreeBSD systems), but I was thinking of doing a dual-boot with Linux to try that out.
avatar
wongheiming: Just install FTL under Ubuntu 16.04 inside VirtualBox and test it out.
The mouse pointer moves slow, but not to the extend as you describe.
Is it possible your hand movement is too fast and wide, and not get used to the speed?
It's pretty drastic in my case. I went through the tutorial and started a new game, and still hadn't gotten used to it. It's true that pausing the game means I'm not getting killed while I try to click on things, but it's just painful to have to "ease up" on every click instead of just moving and clicking.

I'm glad you mentioned 3D Acceleration; I'll try tweaking some of those settings in VirtualBox and see if that helps.
Post edited January 01, 2017 by aaronbaugher
avatar
aaronbaugher: I don't currently have a native Windows or Linux system (I'm running VirtualBox on FreeBSD systems), but I was thinking of doing a dual-boot with Linux to try that out.
The older Window's builds ran quite well for me in Linux via Wine (GeForce 8800 GTX-proprietary).
Post edited January 01, 2017 by Gydion
Turning on 3D Acceleration for the Linux guest fixed the mouse problem completely, but then I had the problem you had, where things went transparent about halfway through the tutorial, making messages very hard to read.

So I tried the Vista guest, again turning on 3D Acceleration in the VirtualBox settings. This fixed the mouse problem too, but the transparency issue didn't show up, so I think it's fixed and I can play it in that system.

Thanks for your help!
Isn't there a linux compatibility package for bsd?
I have the same problem on native Windows 10. It is very annoying during the game, as I have to pause any time I need to make an order with my mouse.
Toggling V-Sync or Full Screen does not change anything.
I can run GTA V @ 4k@30Hz, but FTL lags? That is unbelievable.
avatar
lostfreeman: I have the same problem on native Windows 10. It is very annoying during the game, as I have to pause any time I need to make an order with my mouse.
Toggling V-Sync or Full Screen does not change anything.
I can run GTA V @ 4k@30Hz, but FTL lags? That is unbelievable.
This thread is about VM...

Right click of exectuable > properties > Compatibility tab > disable high dpi resizing

If this does not help, then go to video drivers and manually set them to high-performance profile.