It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello.

Recently bought an ACER Predator laptop and installed GOG Galaxy along with FTL.
But as soon as I start it up, it shows "LOADING" and the bar. Fills up a few before it freezes and nothing else happens.
Tried verifying/repairing, tried reinstalling it, nothing.

Laptop Specs is as follows:

Nvidia GeForce GTX 1060 with 6GB RAM
Intel® Core™ i7-8750H hexa-core-processor
-------------------------------------------------------------------------------------------------------------- ----------------------------------------------------
THIS POST IS CONCLUDED!

I tried everything suggested, but after a while and many updates of various software etc, it worked!
I can't explain it.
Attachments:
Post edited April 20, 2019 by x5129119
No posts in this topic were marked as the solution yet. If you can help, add your reply
Update your computer. With Windows you will have to repeat updating many times for it to get up to date.
avatar
Themken: Update your computer. With Windows you will have to repeat updating many times for it to get up to date.
- Done that. Nothing. Still happens.
avatar
x5129119:
Oh, it sure seemed like that could have been the problem. Graphics drivers updated? PC manufacturer updates updated? You did a cold boot (complete shut down and new start) too, right?

Did you check out the Galaxy sticky thread yet? It might be a Galaxy problem. Is there some repair option in Galaxy? I do not use it myself so a bit hazy on how it works.

<off to play some FTL>
avatar
x5129119:
avatar
Themken: Oh, it sure seemed like that could have been the problem. Graphics drivers updated? PC manufacturer updates updated? You did a cold boot (complete shut down and new start) too, right?

Did you check out the Galaxy sticky thread yet? It might be a Galaxy problem. Is there some repair option in Galaxy? I do not use it myself so a bit hazy on how it works.

<off to play some FTL>
- Graphics and manufactorer must be updated as I got the laptop on TUE. But I will double-check for good measure. And I did. I also did something odd. I started the game, it loaded 50%, then froze. I let it run for 25-35mins while I was at the store. Just to see. Nothing. And I don't think it is a Galaxy prob. I can play other games fine.
Post edited August 23, 2018 by x5129119
I reviewed my Main PC's FTL and done nothing to it, though however..

Maybe I should install Microsoft Visual C++..? The runtimes or whatever that STEAM forces you to download before playing some of their games?

(...I know I said the S-word.)
Good News Everyone!

By some miracle, FTL: Faster Than Light Advanced Edition works now.
I do not know how, but it works.
My theory is that I did not have Microsoft Visual C++ installed which I didn't at the time of my 1st install of this game on my new G-Laptop.
But after installing another game, unsure which one.. It got installed and now it runs.

But I appreciate Themken's input on the matter! He provided a few pointers.
It NEVER HURTS TO DOUBLE-CHECK, Peeps.
Always double-check and then maybe even triple-check to make for absolute certainty.
Attachments:
Post edited August 27, 2018 by x5129119
It should have suggested you to install the Visual C++ libraries when you installed it. Me, I installed FTL only in Linux so not seen how it goes in Windows.

Glad you got it working :-)
avatar
Themken: It should have suggested you to install the Visual C++ libraries when you installed it. Me, I installed FTL only in Linux so not seen how it goes in Windows.

Glad you got it working :-)
As it so fucking happened ... It was not fixed afterall!
I saw the main menu. I heard the music. I moved the mouse.
I didn't click on New Game or anything! I feel like such a dumbass.

So now, it's back to square one.
Any ideas, Peeps?
Post edited August 27, 2018 by x5129119
avatar
x5129119: … So now, it's back to square one.
Any ideas, Peeps?
To what resolution do you have your monitor set? The game won't start for low resolution, for instance, like <720p, and there may be other resolutions it balks at. Have you raised a trouble ticket with Gog?