It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I installed Frostpunk, and had been playing for several days. Today when I went to launch it, it wouldn't work - something like "frostpunk.exe has changed or been removed'. Indeed, there was no frostpunk.exe in the folder where the game was installed.

I uninstalled from Windows apps control panel, and then attempted to reinstall from the same installation files I had originally (and succesfully) used. (I'm not using Gog Galaxy.) Doing so leads to a series of error dialogs. At about 10% installation progress "Internal error: Expression error 'Runtime Error (at 500:57): Out of string range."
Hitting OK and proceeding, at the final screen (game is installed, exit or launch) I get an error dialog "Runtime Error (at 211:63): Out Of Stack Range". Ok on this immediately gives "Runtime Error (at 211:69): Out Of Stack Range." and OK on that gives "Invalid Opcode". No more errors after that.

Launching from the desktop icon "Windows is searching for Frostpunk.exe. To locate the file yourself, click Browse."
Looking in C:\GOG Games\Frostpunk, there is a Launch Frostpunk shortcut to C:\GOG Games\Frostpunk\Frostpunk.exe, but the Frostpunk.exe file is not there. (Lots of other files are there.)

I've been through this uninstall-reinstall cycle about 3 times, it is always the same. I have tried updating video driver, directX and MS Visual C++ redistributable.

No new software was installed after Frostpunk (except, after problems started, updated video driver, directX, C++ redistributable.)

Windows 10 Home, version 1903, OS build 18362.418.
Intel i5-4670
GeForce GTX 1050 Ti

Installation files are

I had the bright idea of rebooting windows and trying again. In the process, Windows installed some update (I don't know if that is relevant). After reboot, the reinstall worked without error.
Thanks for the update !
I got the same issue today : the .exe just vanished, but the launcher (here the beta of Gog Galaxy 2.0) didn't considered the game as installed, so no file verification was possible.
I tried uninstalling/reinstalling, but the install was always aborted in the process.

The solution in my case was installing a cumulative update that was waiting in windows update : KB4522355 Windows 10 cumulative update. But, also here, this update always failed to install. So I desactived my antivirus, waited about 20 min, then rebooted the computer, and the game would finally be successfully installed.

Hope it will help someone if needed :)