It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi - I've just played FS1 for the first time, and straightaway there seems to be a problem.

Most, but not all, of the game's text displays flicker and flash. It'll be impossible to even think of playing the game with such a distraction - not to mention it'll give you migraines like the old Amiga "interlace mode" used to!!!!!

This is just the front-end "inside the base" and the options screens! Not even gotten to any 3D bits yet!!!!!

PS/ Now I have..... utter disaster..... the whole screen and everything on it flickers, jitters and vanishes..... violently.
Totally unplayable.

Looking at these forums looks like loads of people are having GFX trouble with this one..... (I might even have declined to buy it if i'd looked here first), but not *this* specific problem. Anyone know whats wrong?

I can never remember my system details much, but it is a 2.8 AMD Quad Core, GPU is an old NVidia GTX2600 if I remember right. And its Windows XP SP3.

Tried simple measures such as "compatability modes", and no effect.


PS/ Freespace 2 is exactly the same, same glitches, same crazy flicker/flashing, weird graphical corruption smudge like artifacts. Sore odd graphical glitches seem to persist in Windows even after quitting the game!!!!!

Thanks GOG..... so much for this "it works, we promise" policy.
Post edited November 16, 2014 by JMayer70
No posts in this topic were marked as the solution yet. If you can help, add your reply
Please try to be a bit less negative.

Anyway, I was having this problem too. I found an old message about this on this forum--don't have it handy.

The fix is to go to the directory and start the freespace.exe app directly. This gives you the screen with the "Setup" button, where you can detect and set the 3D acceleration. I turned it off an the text quit flickering. I'll post if I run into other issues.
First off, let me say this:- these two Freespace games have been the 10th and 11th GOG games in a row that have either disappointed, been full of bugs or plain not worked at all. I reckon I have a damn good right to be negative.

Anyway - your solution worked fine for Freespace 1. I was able to run it in software mode - which meant the GFX were the minimum possible quality, but the game was still playable. So far so good - TY Mughi!

However it still leaves Freespace 2 - FS2's setup gives no software mode option - only 3D accelerated modes, and NONE of those work, they all suffer massive GFX and text disruptions and flashing. The game won't even attempt to run if you try to select "No 3D acceleration".
So I'll try out this FS2 Open Source Project thing - hope it isn't too much pissing about.
Post edited November 22, 2014 by JMayer70
I'm having this issue too. I don't even have access to any setup to select graphic modes though.
i have the same problem
People are still having trouble with Freespace 2, direct from GOG and "out of the box"?

GOG, you really should get your acts together - you're selling a defective product here, and it seems like even after two years you've done jack to fix it.

Here's something for "subliminal.state" and "jrnyman3" to try, if they have not already.
That "Freespace Open Source Project" did work..... though it was an enormous undertaking. The download time was huge, and the installation an absolute piss-take of awkwardness and obfuscation! The games were barely even worth the effort. In fact, this "FS OSP" were NOT the "originals" as supplied by GOG. They were 100% complete fan-community rewrites of them both, all rolled into one (which helped making setting it up so complicated). But it was not standalone, you still had to own an original boxed copy, or the GOG copy, of FS1 and FS2 to make it work. This was no FREE open source! Can't blame them, somebody did an awful lot of work!

It's so long ago I don't remember the address of the site you'd need..... but Googling "Freespace Open Source" should still find it.
Post edited December 17, 2016 by JMayer70