It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Greets one and all,
So, having a bit of joystick issues that so far, I haven't noticed answered in any other threads.
I have a Saitek ST290 Pro and it refuses to be picked up in Freespace 2. I've tried updating the drivers, the software and still nothing. I've also after reading these forums, gone into the launcher and selected it there - still nothing. I've done everything I can think of up until now.
However, it does work on a Microsoft Sidewinder I have - just not perfectly ideal I find it since the Saitek is more of a flight-stick than the 'winder is as a joystick. It's all a matter of comfort.
So if anyone has similar issues or can point in me in the right direction, be much obliged! :)
This question / problem has been solved by Jeff Vaderimage
Have you concidered trying FreeSpace Open? You don't have to download all the graphics stuff and mods; just grab the FSO engine, the FSO Launcher and use them instead of the original FS2 engine and launcher. I don't know anything about joysticks, but it's always worth a shot. Installation instructions are available at,47640.0.html . No need to go through it all, if you don't want. Steps 2,3,4, 5 and 8 should suffice for you.
Yep, that worked a charm! She picks up my 'stick now - with the added bonus of everything looking that good deal shiner. Thank you sir!
Just an FYI to anyone else with this problem. I have a Logitech Wingman Extreme Digital running through a Manhattan joystick to UISB adapter in mode 1 and this solution also worked for me. FS1 worked with it just fine, but the FS2 launcher would detect it and let me choose it, but it was unresponsive in the game. Now it works like it's supposed to. Thanks JV for the answer.
Post edited June 25, 2009 by Hypurr
Post edited March 10, 2012 by 4Strings