It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've reported this last week, but noone replied to me about that matter. Whether they know, whether it will ever be fixed. Nothing. So I'm informing you about this here:
They claim that the game is patched to 1.20. The truth is only the binaries seem to be. 1.20 patch brought also a patched version of Root_fs2.vp file. This file is NOT patched in GOG installation (even the readme is from 1.00 version). So the all mission fixes made in 1.20 are not included here. I really hope GOG will do something about it, fixed install file would be most appreciate.
The 1.00 Root_fs2.vp file size is: 5,573,029
The 1.20 Root_fs2.vp file size is: 6,404,494
from 1.20 readme:
Version Changes
- Initial release
- Fixed Win95 CD detection problem
- Glide texture stretching fix
- Standalone server CD checking fix
- Jump Node placement in Fred2
- Pilot's score added to multiplayer debriefing
- Technical database does not show duplicates of each weapon
- Intro movie no longer shows up twice in cutscene player after campaign
- Objectives in Templar campaign assigned points
- Wingmen now receive a score bonus when large ships are destroyed
- Mission 3-4 conversation added
- Templar 3 mission objective text altered
- M-02 debriefing /Return to base issues fixed
- Mission 3-7 messages changed to accurately reflect mission occurrences
- Loop 2-1 directives issue resolved
- Mission 1-4 failure debriefing added
- Loop 1-2 message timing optimized
- Loop 2-2 directives cleaned up
- Agrippa persona fixed in mission 3-5
- Loop 1-3 mission outcome for blowing up civilians fixed
- Loop 1-3 in mission messaging fixed
- Mission 1-8 briefing icons fixed
- Mission 1-9 debriefing typos fixed
- Mission 1-5 Discovery/Trinity personas fixed
- Training 5 directives cleared up
- Mission 3-1 message timing optimized
- Mission 3-6 directives corrected
- Mission 3-8 briefing icons corrected
- Mission 3-9 alternate names removed from ships
- Mission 3-9 weapons loadout fixed
- Cyclops bomb names fixed
- Mission 2-7 directives fixed
Post edited October 14, 2008 by Havner
They replied and seems it will get fixed soon :-)
Good job.
I also reported this issue.
Hopefully some sort of notification will appear on our accounts to inform us to download a patch or update to fix it.
Well, has this problem fix'd?
henuman: Well, has this problem fix'd?

Looks fixed
Can anyone confirm if it is truly fixed?
And, if it is, can someone from confirm when exactly it's been fixed? I'd like to know if I have to redownload it or not. ;-)
I downloaded the copy I am playing with a few days ago (2-3 days ago) and Root_fs2.vp is now 6,404,494.
So yeah that file appears to be truly fixed.
Wait, so if I want my freespace 2 fully updated, I'd need to uninstall and re download my game?
Somethingfake: Wait, so if I want my freespace 2 fully updated, I'd need to uninstall and re download my game?

It looks like it. I tried installing over top but it doesn't seem to copy anything. You don't need to delete save game files to update this though.
I had to uninstall some time ago and I decided to redownload the .exe and re-do the installation. Using Gameshadow, it still show as 1.00. I grabbed a 1.20 patch from it's (Gameshadows) servers, yet as I tried to patch it gave the old error known to everyone about not being able to fine the old file.
I guess the GoG version, being part 1.20 from what the OP says, makes it unpatchable through normal means.
I'd really like to now if GoG even got my e-mail, sent several weeks ago and so far with no reply.
Got to say, signing up, paying for and downloading a game here is a snap. Actually hearing from GoG is another story.