It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi. I tried starting a new campaign and after showing the intro with the superhero list, it hangs at a black screen.

Same thing when I try starting a new rumble room instance.
Having the same issue here. Tried running as Admin and in compatibility mode (XP SP2), to no avail.

Windows 10 64 Bit
AMD FX 8350 8-Core, 4.00 GHz
16 GB Ram
AMD Radeon R9270X

Does anyone have any suggestions? Thanks in advance!

Howdy folks, is this for FF1 or 2?

I'm afraid I don't know what could be causing this if it is for 2. It SHOULD work with Admin and comparability for XP SP 2. You might also try running it in earlier modes if you're talking about FF1.

Otherwise, try heading over to the FF community home at There are a lot of materials there that could be helpful, as well as an awesome group of people who might be able to figure things out for you.