It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I have tried the fix mentioned in "Freedom Force Fix" but I just cannot get the game running on my Book II (Win 11 Home Edition). Screen goes black and there is a short chopped off sound and then it reverts back to the GOG Galaxy page. Any pointers?
avatar
Argamae: I have tried the fix mentioned in "Freedom Force Fix" but I just cannot get the game running on my Book II (Win 11 Home Edition). Screen goes black and there is a short chopped off sound and then it reverts back to the GOG Galaxy page. Any pointers?
I was able to get the game running on Windows 11 setting compatibility mode to XP SP2, checking the run as admin box then starting the game in windowed mode. Check the install folder for the Launch Freedom Force shortcut check the properties and in the target path add -window after the .exe" then apply it. Boot up the game and once it starts change your resolution in game for example I used 1440x1080 for 4:3 then exit the game. Then go back to the shortcut and remove the -window click apply and run the game full screen again and it should boot up fine at least for me it did. Hope this helps.
avatar
Argamae: I have tried the fix mentioned in "Freedom Force Fix" but I just cannot get the game running on my Book II (Win 11 Home Edition). Screen goes black and there is a short chopped off sound and then it reverts back to the GOG Galaxy page. Any pointers?
avatar
baphoon: I was able to get the game running on Windows 11 setting compatibility mode to XP SP2, checking the run as admin box then starting the game in windowed mode. Check the install folder for the Launch Freedom Force shortcut check the properties and in the target path add -window after the .exe" then apply it. Boot up the game and once it starts change your resolution in game for example I used 1440x1080 for 4:3 then exit the game. Then go back to the shortcut and remove the -window click apply and run the game full screen again and it should boot up fine at least for me it did. Hope this helps.
No luck for me, window pops up briefly then it all stops. I'm on a laptop so don't know if that will make a difference.
avatar
Argamae: I have tried the fix mentioned in "Freedom Force Fix" but I just cannot get the game running on my Book II (Win 11 Home Edition). Screen goes black and there is a short chopped off sound and then it reverts back to the GOG Galaxy page. Any pointers?
Someone on a different thread mentioned changing the name of 'fforce.exe'. I removed one f (it's 'force.exe' now), and it worked.