It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

something strange happened to me:
i was exploring the maze surrounding the boss tower, teleporter were working fine (random tp when steped in), the bushes also were working fine (possible to step through but poison one car and chance to die).
And suddenly, i think, that happened when i finished to explore the maze, the last step, the tp stopped to work, bushes were unpenetrable and no event occurs inside the tower.
When i go to the location (according to the clue book) where i meet the fake th...boss, the room is empty and nothing happen. The second entrance have invisible door on the south and a stair leading nowhere. I am unable to meet the last boss and finishing the game :/

I play with GBC and have dup some item (like the sword +4), more or less have maxed out my char but nothing undoable with the game's rules (i e car are legit and good items duplicated).

Could it be a kind of item dup protection, a bug from gog, a bug from gbc, a native well known bug from por etc???

I ve tried playing the previous save game and still unable to have encounter in the middle tower, tried to reinstall the game, still no encounter and no way to fight the last battle.

Any help would be appreciated :)

edit: ok problem solved.
I used my previous saved game, which was in front of the gate (the big gate to the maze), walk throught the door another time, et voila, everything was fixed. Strange. When i tped using gbc from the outside of the gate to the entrance of the fake boss, nothing was triggered when i entered the fake boss room. But when i tped with gbc AFTER stepping throught the big gate, everything went back to normal.
I thing that at a moment i went out to farm several hill giant encounter and when i went back in the maze throught the gate, i was still encountering the hill giant and not the snakes. The game may have messed up at this moment, and strangely, it messed up all the game and gamesave, with or without re installation. But with a save prior to the encounter confusion and the fact to move again from the hill giant zone to the maze zone, it fixed everything, at least for my previous uncorrupted save.
If somebody have an explanation, i ll be happy to hear it ;)

Just finished the game, 650xp for the, a little disapointing hé hé. Now i have another problem, my last save recognized by gbc is before i stepped into the last floor of the boss, while the game recognize all the save i made after... 60 hours without a single bug and everything went wrong in the last one lol.

great game btw, thx to gog for having it back :)
Post edited September 14, 2019 by galdom
Sounds like the map events for the maze and castle interior were not loaded properly. Events are scripts that are tied to certain map locations.