It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've installed PoR and PoD from the Gold Box games on my windows tab (HP Stream 7) running Windows 8 but nothing's happening when I try to launch them. I've tried changing the DOSBOX graphics settings in the config editor but nothings working. No error message, no window opening then crashing. Checking the task manager while starting it seems to suggest it's not even trying to open Dosbox.

I know it's not simply incompatibility with the tablet because Wizardry 6 runs just fine on Doxbox on the tablet, running it in exactly the same way from Galaxy. Any ideas? I can see that Galaxy thinks I've run the game because it shows '1 minute ago' as the last time I played after I try to start it.
Post edited August 25, 2015 by Themadcow5
No posts in this topic were marked as the solution yet. If you can help, add your reply
Solved by another member elsewhere - turns out that this particular version of DOSBOX didn't like my touchscreen input, but plugging in a mouse to the tablet worked fine. Not ideal but now I know what the issue is I'm sure there's a fix.