It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
When doing sh start.sh I get

Running FlatOut
[drunk][09/11/2017_21:04:17] WINEDEBUG=trace+x11settings
[drunk][09/11/2017_21:04:17] WINEDLLOVERRIDES=mscoree,mshtml=
[drunk][09/11/2017_21:04:17] WINEPREFIX=/home/marek/GOG Games/FlatOut/drunk/../prefix/
[drunk][09/11/2017_21:04:17] starting wine
[drunk][09/11/2017_21:04:17] starting drunk daemon
[drunkd][09/11/2017_21:04:17] preparing to start drunkd
[drunkd][09/11/2017_21:04:17] primary display device detected as: DisplayPort-0
[drunkd][09/11/2017_21:04:17] current resolution stored: 2560x1440
[drunk][09/11/2017_21:04:18] waiting for flatout.exe to start
[drunk][09/11/2017_21:04:18] flatout.exe started
[drunkd][09/11/2017_21:04:18] drunkd started
[drunkd][09/11/2017_21:04:18] observing: flatout.exe

And it stays there forever.
It works when I try to run windows version through wine without messing around with anything. Same thing happens with Flatout2, though I didn't try with windows version of this one.

I know Arch Linux is not supported, but maybe somebody had simmilar issue here?
avatar
jedza: When doing sh start.sh I get

Running FlatOut
[drunk][09/11/2017_21:04:17] WINEDEBUG=trace+x11settings
[drunk][09/11/2017_21:04:17] WINEDLLOVERRIDES=mscoree,mshtml=
[drunk][09/11/2017_21:04:17] WINEPREFIX=/home/marek/GOG Games/FlatOut/drunk/../prefix/
[drunk][09/11/2017_21:04:17] starting wine
[drunk][09/11/2017_21:04:17] starting drunk daemon
[drunkd][09/11/2017_21:04:17] preparing to start drunkd
[drunkd][09/11/2017_21:04:17] primary display device detected as: DisplayPort-0
[drunkd][09/11/2017_21:04:17] current resolution stored: 2560x1440
[drunk][09/11/2017_21:04:18] waiting for flatout.exe to start
[drunk][09/11/2017_21:04:18] flatout.exe started
[drunkd][09/11/2017_21:04:18] drunkd started
[drunkd][09/11/2017_21:04:18] observing: flatout.exe

And it stays there forever.
It works when I try to run windows version through wine without messing around with anything. Same thing happens with Flatout2, though I didn't try with windows version of this one.

I know Arch Linux is not supported, but maybe somebody had simmilar issue here?
Hi jedza!

What do you mean by "it stays there forever"? How long did you wait? The game needs to configure its Wine prefix on the first run and it takes a longer while (probably about a minute, but this might differ).

Please also make sure that you installed your local 32 bit Wine package, as it is needed to satisfy game dependencies.

Could you provide a detailed system report of your machine? It can be generated using the script that you will find in the installation path. If you are not comfortable posting this kind of information here, you can also contact our support: https://support.gog.com/
avatar
jedza: When doing sh start.sh I get

Running FlatOut
[drunk][09/11/2017_21:04:17] WINEDEBUG=trace+x11settings
[drunk][09/11/2017_21:04:17] WINEDLLOVERRIDES=mscoree,mshtml=
[drunk][09/11/2017_21:04:17] WINEPREFIX=/home/marek/GOG Games/FlatOut/drunk/../prefix/
[drunk][09/11/2017_21:04:17] starting wine
[drunk][09/11/2017_21:04:17] starting drunk daemon
[drunkd][09/11/2017_21:04:17] preparing to start drunkd
[drunkd][09/11/2017_21:04:17] primary display device detected as: DisplayPort-0
[drunkd][09/11/2017_21:04:17] current resolution stored: 2560x1440
[drunk][09/11/2017_21:04:18] waiting for flatout.exe to start
[drunk][09/11/2017_21:04:18] flatout.exe started
[drunkd][09/11/2017_21:04:18] drunkd started
[drunkd][09/11/2017_21:04:18] observing: flatout.exe

And it stays there forever.
It works when I try to run windows version through wine without messing around with anything. Same thing happens with Flatout2, though I didn't try with windows version of this one.

I know Arch Linux is not supported, but maybe somebody had simmilar issue here?
avatar
linuxvangog: Hi jedza!

What do you mean by "it stays there forever"? How long did you wait? The game needs to configure its Wine prefix on the first run and it takes a longer while (probably about a minute, but this might differ).

Please also make sure that you installed your local 32 bit Wine package, as it is needed to satisfy game dependencies.

Could you provide a detailed system report of your machine? It can be generated using the script that you will find in the installation path. If you are not comfortable posting this kind of information here, you can also contact our support: https://support.gog.com/
By forever I mean it was like 15 minutes at least when I let it run on its own.

I don't know if there even is separate wine package for 32 bit, I thought it's all handled by prefixes. When I googled 'ubuntu wine 32bit' I see that it also is handled that way.

I don't mind sharing it here, but can't attach it cause of 'wrong file format'. Tried ziping it, and it's the same, so I uploaded it to sendspace:
https://www.sendspace.com/file/kuswd1
Post edited November 11, 2017 by jedza
avatar
jedza: By forever I mean it was like 15 minutes at least when I let it run on its own.

I don't know if there even is separate wine package for 32 bit, I thought it's all handled by prefixes. When I googled 'ubuntu wine 32bit' I see that it also is handled that way.

I don't mind sharing it here, but can't attach it cause of 'wrong file format'. Tried ziping it, and it's the same, so I uploaded it to sendspace:
https://www.sendspace.com/file/kuswd1
Could you try checking if there is a (hidden) log file in the following path:

/home/marek/GOG Games/FlatOut/drunk/.tmp_x11.log

If yes, please provide it's contents.

If not, please create an empty file with this name in the specified path.

Please also check if the game works in windowed mode (virtual desktop). To do that, either use a game shortcut in your menu or use the launch script in the game installation path with the right parameter:

./start.sh -w
avatar
jedza: By forever I mean it was like 15 minutes at least when I let it run on its own.

I don't know if there even is separate wine package for 32 bit, I thought it's all handled by prefixes. When I googled 'ubuntu wine 32bit' I see that it also is handled that way.

I don't mind sharing it here, but can't attach it cause of 'wrong file format'. Tried ziping it, and it's the same, so I uploaded it to sendspace:
https://www.sendspace.com/file/kuswd1
avatar
linuxvangog: Could you try checking if there is a (hidden) log file in the following path:

/home/marek/GOG Games/FlatOut/drunk/.tmp_x11.log

If yes, please provide it's contents.

If not, please create an empty file with this name in the specified path.

Please also check if the game works in windowed mode (virtual desktop). To do that, either use a game shortcut in your menu or use the launch script in the game installation path with the right parameter:

./start.sh -w
running with -w doesn't work either. There was no .tmp_x11.log, and after I created it, only thing appearing there is
fixme:console:CONSOLE_DefaultHandler Terminating process 8 on event 0
after I finally press ctrl+c, to stop the script
avatar
linuxvangog: Could you try checking if there is a (hidden) log file in the following path:

/home/marek/GOG Games/FlatOut/drunk/.tmp_x11.log

If yes, please provide it's contents.

If not, please create an empty file with this name in the specified path.

Please also check if the game works in windowed mode (virtual desktop). To do that, either use a game shortcut in your menu or use the launch script in the game installation path with the right parameter:

./start.sh -w
avatar
jedza: running with -w doesn't work either. There was no .tmp_x11.log, and after I created it, only thing appearing there is
fixme:console:CONSOLE_DefaultHandler Terminating process 8 on event 0
after I finally press ctrl+c, to stop the script
I'm sorry, I am unable to reproduce your issue. You might try to run it with bash instead of sh, just to be sure.

If you're not satisfied with your workaround (running the game directly in Wine instead of using our wrapper), you can contact our support: https://support.gog.com/
avatar
jedza: running with -w doesn't work either. There was no .tmp_x11.log, and after I created it, only thing appearing there is
fixme:console:CONSOLE_DefaultHandler Terminating process 8 on event 0
after I finally press ctrl+c, to stop the script
avatar
linuxvangog: I'm sorry, I am unable to reproduce your issue. You might try to run it with bash instead of sh, just to be sure.

If you're not satisfied with your workaround (running the game directly in Wine instead of using our wrapper), you can contact our support: https://support.gog.com/
Nah, I'm fine with that, though Flatout 2 doesn't run either way.
When ran with your script, though, it crashes, doesn't keep running forever, and here is .tmp_x11.log output:
winedbg: Internal crash at 0x7e8bac64
And if I try to run it with wine I get dialog window Fatal error with message 'Failed to create effect: data/shader/pro_static2x.sha'.
avatar
linuxvangog: I'm sorry, I am unable to reproduce your issue. You might try to run it with bash instead of sh, just to be sure.

If you're not satisfied with your workaround (running the game directly in Wine instead of using our wrapper), you can contact our support: https://support.gog.com/
avatar
jedza: Nah, I'm fine with that, though Flatout 2 doesn't run either way.
When ran with your script, though, it crashes, doesn't keep running forever, and here is .tmp_x11.log output:
winedbg: Internal crash at 0x7e8bac64
And if I try to run it with wine I get dialog window Fatal error with message 'Failed to create effect: data/shader/pro_static2x.sha'.
At this point I expect something either video card related or display related, but I have no way to check this. That's why I suggested you run the game in windowed mode (virtual desktop). You could also tinker with the settings launcher.
avatar
jedza: Nah, I'm fine with that, though Flatout 2 doesn't run either way.
When ran with your script, though, it crashes, doesn't keep running forever, and here is .tmp_x11.log output:
winedbg: Internal crash at 0x7e8bac64
And if I try to run it with wine I get dialog window Fatal error with message 'Failed to create effect: data/shader/pro_static2x.sha'.
avatar
linuxvangog: At this point I expect something either video card related or display related, but I have no way to check this. That's why I suggested you run the game in windowed mode (virtual desktop). You could also tinker with the settings launcher.
Turning everything off in settings launcher doesn't help, neither does running it in windowed mode, I'm on RX570, so, still a bit less supported side of Linux graphics cards, so it might be the reason, though I also tried with wine with gallium-nine patches, that is supposed to be super great thing if on AMD, but didn't work there either.
avatar
jedza: Turning everything off in settings launcher doesn't help, neither does running it in windowed mode, I'm on RX570, so, still a bit less supported side of Linux graphics cards, so it might be the reason, though I also tried with wine with gallium-nine patches, that is supposed to be super great thing if on AMD, but didn't work there either.
Same here on Arch. But I am using an Nvidia GTX 1070. I highly doubt it's graphics-related as Nvidia has solid support. I got a:

wine: Unhandled page fault on read access to 0x00000004 at address 0x7eb5dc64 (thread 002b), starting debugger...

I must admit, I took the easy route out and just used my system's wine (3.0rc4-1) instead of diagnosing more: Merely replace all instances of "${drunk_wine}/bin/wine" (and similar) with "/bin/wine" in drunk/drunk.sh
Post edited January 01, 2018 by Chauncellor
avatar
jedza: When doing sh start.sh I get

Running FlatOut
[drunk][09/11/2017_21:04:17] WINEDEBUG=trace+x11settings
[drunk][09/11/2017_21:04:17] WINEDLLOVERRIDES=mscoree,mshtml=
[drunk][09/11/2017_21:04:17] WINEPREFIX=/home/marek/GOG Games/FlatOut/drunk/../prefix/
[drunk][09/11/2017_21:04:17] starting wine
[drunk][09/11/2017_21:04:17] starting drunk daemon
[drunkd][09/11/2017_21:04:17] preparing to start drunkd
[drunkd][09/11/2017_21:04:17] primary display device detected as: DisplayPort-0
[drunkd][09/11/2017_21:04:17] current resolution stored: 2560x1440
[drunk][09/11/2017_21:04:18] waiting for flatout.exe to start
[drunk][09/11/2017_21:04:18] flatout.exe started
[drunkd][09/11/2017_21:04:18] drunkd started
[drunkd][09/11/2017_21:04:18] observing: flatout.exe

And it stays there forever.
It works when I try to run windows version through wine without messing around with anything. Same thing happens with Flatout2, though I didn't try with windows version of this one.

I know Arch Linux is not supported, but maybe somebody had simmilar issue here?
Edit

Hello,

I installed it yesterday and it looks like the version of wine that come with the game is not working on arch. I modified drunk.sh so it call the version of wine that is installed on my computer. drunk.sh is in "GOG Games/FlatOut 2/drunk". You have to replace

"${current_dir}/../${drunk_wine}/bin/wine"

by

"/usr/bin/wine"

or the path to any wine binary you want to use to launch the game in the lines 84 and 92.
There might be a better solution but it works.

https://bbs.archlinux.org/viewtopic.php?id=231749


drunk.sh -- My file edit settings below which worked for me.
---8><--- Cut and paste..

#!/bin/bash
# Drunk Primary Library
app_version="0.7.5"
app_name="drunk"

source "drunk/src/option_parser.sh"
current_dir="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"

drunk_log() {
echo "[drunk][$(date '+%d/%m/%Y_%H:%M:%S')] ${1}"
}

define_argument "-p" "--game-path" "$@"
drunk_game_path="$OP_LAST_ARGUMENT_VALUE"
define_argument "-e" "--game-exe" "$@"
drunk_game_exe="$OP_LAST_ARGUMENT_VALUE"
define_argument "-a" "--args" "$@"
drunk_game_args="$OP_LAST_ARGUMENT_VALUE"
define_argument "-x" "--prefix" "$@"
drunk_prefix="$OP_LAST_ARGUMENT_VALUE"
define_argument "-w" "--wine" "$@"
drunk_wine="$OP_LAST_ARGUMENT_VALUE"
define_argument "-m" "--custom-command" "$@"
drunk_custom_command="$OP_LAST_ARGUMENT_VALUE"
define_argument "-o" "--daemon-on-off" "$@"
drunk_daemon_on_off="$OP_LAST_ARGUMENT_VALUE"

if [ -z "${drunk_daemon_on_off}" ]; then
drunk_daemon_on_off="on"
fi

drunk_wine_export() {
export WINEDEBUG="trace+x11settings"
drunk_log "WINEDEBUG=${WINEDEBUG}"
export WINEDLLOVERRIDES="mscoree,mshtml="
drunk_log "WINEDLLOVERRIDES=${WINEDLLOVERRIDES}"
export WINEPREFIX="${current_dir}/../${drunk_prefix}/"
drunk_log "WINEPREFIX=${WINEPREFIX}"
}


drunk_start_daemon(){
if [ "${drunk_daemon_on_off}" == "on" ]; then
drunk_log "starting drunk daemon"
x11log="${current_dir}/.tmp_x11.log" . "${current_dir}/src/drunkd.sh"
fi
}

drunk_custom(){
drunk_wine_export
drunk_log "custom command, setting WINEDEBUG to none"
export WINEDEBUG="-all"
drunk_log "WINEDEBUG=${WINEDEBUG}"
if [ -z "${1}" ]
then
"${drunk_wine}/bin/wine" "${drunk_custom_command}"
else
"${drunk_wine}/bin/wine" "${1}"
fi
}

drunk_regedit(){
drunk_custom regedit
}

drunk_winecfg(){
drunk_custom winecfg
}

drunk_winecmd(){
drunk_custom cmd
}

drunk_winetricks(){
drunk_wine_export
"${current_dir}/src/winetricks"
}

drunk_run_game() {
drunk_wine_export
drunk_start_daemon & disown
drunk_log "starting wine"
cd "${WINEPREFIX}/${drunk_game_path}"
"/usr/bin/wine" "${drunk_game_exe}" "${drunk_game_args}" >> "${current_dir}/.tmp_x11.log" 2>&1
drunk_log "wine run ended"
}

drunk_run_game_virtual() {
drunk_wine_export
drunk_log "starting wine in virtual desktop mode"
cd "${WINEPREFIX}/${drunk_game_path}"
"/usr/bin/wine" explorer /desktop="GOG","640x480" "${drunk_game_exe}" "${drunk_game_args}" > "/dev/null" 2>&1
drunk_log "wine run ended"
}

drunk_help() {
echo "drunk (GOG.com)"
echo "state-of-the-art GOG.com-wine framework for running non-native games"
echo " "
echo "usage: drunk/drunk.sh [switch] [argument]"
echo " "
echo "switches:"
echo "-r, --run run wine game in normal mode"
echo "-t, --run-virtual run wine game in virtual desktop mode"
echo "-f, --winecfg run winecfg"
echo "-g, --regedit run wine regedit"
echo "-d, --cmd run wine cmd"
echo "-k, --winetricks run winetricks"
echo "-c, --custom run custom command in wine"
echo " "
echo "arguments:"
echo "-p, --game-path path to windows binary (in the prefix)"
echo "-e, --game-exe name of the windows binary"
echo "-a, --args arguments for the binary"
echo "-x, --prefix relative path to wine prefix"
echo "-w, --wine path to wine"
echo "-m, --custom-command specify custom wine command"
echo "-o, --daemon-on-off set if daemon is on or off (on by default)"
echo " "
echo "-h, --help print help for this command"
echo " "
echo "examples:"
echo " "
echo "to start the game:"
echo "drunk/drunk.sh -x \"prefix\" -p \"drive_c/GOG Games/Game/\" -e \"Game.exe\" -w \"drunk/wine/1.6.2/\" --run"
echo " "
echo "to run winecfg in the game prefix:"
echo "drunk/drunk.sh -x \"prefix\" -w \"drunk/wine/1.6.2/\" --winecfg"
echo " "
echo "to pass a custom exe or command to wine in the game prefix:"
echo "drunk/drunk.sh -x \"prefix\" -w \"drunk/wine/1.6.2/\" -m \"unofficial_patch_installer.exe\" --custom"
echo " "

}

define_switch "-r" "--run" "drunk_run_game" "$@"
define_switch "-t" "--run-virtual" "drunk_run_game_virtual" "$@"
define_switch "-c" "--custom" "drunk_custom" "$@"
define_switch "-f" "--winecfg" "drunk_winecfg" "$@"
define_switch "-g" "--regedit" "drunk_regedit" "$@"
define_switch "-d" "--cmd" "drunk_winecmd" "$@"
define_switch "-k" "--winetricks" "drunk_winetricks" "$@"

define_switch "-h" "--help" "drunk_help" "$@"
Thanks NWAFIVE. That got mine working on Manjaro.
Thanks, the patched drunk.sh works also on Ubuntu 18.04.
Same problem here on Linux Mint 19. I'll wait for GoG to fix their installer.