It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Has anyone else had this problem? At the part where you pick up the transporter, Conrad can't go down and just walks on where the elevator used to be. Is there any workaround on this? I'd much prefer not to replay the entire level if possible.
No posts in this topic were marked as the solution yet. If you can help, add your reply
What have you tried? Rolling? Going off screen and back? Climbing down? A restart won't really set you all that far back, though.
Never happened to me, either in this version or any other. Did you come into that screen from below?
Yup, tried rolling, going off screen and back, climbing down. And this is silly but I've replayed this level a few times already that I wouldn't want to replay it another time. Haven't played this in years so I got stuck in a few places several times (stuck as in used/missed items and and elevators at the wrong time/sequence). If there's really no solution then I guess I'll have to restart... again... ^_^'
Edit: Oh, by this time, I already got the injured man's ID and now trying to get the credits on that area blocked by the elevator.

It sure is quite odd. Never happened to me in the past too. I came from the right-hand side of the screen.
Post edited June 04, 2019 by hirokada