It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

If vsync in this game does not seem to work no matter what you do and if you happen to not run an aero windows theme try to change the desktop theme back to aero. For me it fixed the tearing completely.

Edit: I asked the devs and here is what they've said after examining the issue:

The full screen checkbox option in Firewatch could be more accurately be labeled "Fullscreen borderless window." This is due to a limitation of the version of Unity we shipped on. We had to pick between the version we implemented and exclusive fullscreen (in the traditional sense).

Windows 7 Aero theme enables vsync at the OS level, so for your desktop and critically for windows. Because Firewatch in fullscreen mode is a window (from Window's perspective) running it with the Aero theme active grants all the benefits of vsync.

Regretfully, in your case the workaround to bad screen tearing is indeed to enable the Aero theme on windows 7.

I also asked them if this might be changed in future updates but I have to wait for a response since I just wrote this today. Will update this post in case I receive news.
Post edited April 29, 2016 by MarkoH01