It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

floogles: Can't seem to change the fez language.

I'm running it on a german windows machine, and it defaults to german.

I have tried changing to english in the game settings, but it flips back to german after exiting the setting each time.

Anyone else have this problem?
Have you tried changing the system language?
JudasIscariot: Have you tried changing the system language?
floogles: Thanks for your idea - have tried changing language settings in regional settings in control panel (running xp) but:

- still starts in german

- english option in menu settings still doesn't stick, and reverts to german.

Any other ideas welcome - hopefully this will be patched, since the change language setting inside Fez seems broken, and switching system language just to play a game is not good practice for a 2012 release.
What about running it as admin? Perhaps it's a privileges issue as to why it won't stick to a desired language?