It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I noticed that my frames are well below 30 frames per second on the copy of FEAR that I bought. I would love some help figuring out why I am getting less than playable FPS on this version when I can get above 60 FPS on a pirated or original disc copy of the game. Neeedless to say, even on my potato PC, I SHOULD be able to run it well above 60 frames per second.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Not really, even on modern feastest PC and being old game this isn't really benchmark or angel of optimization, suffer memory leaks from time to time or hit 100% CPU at random points when models do something over the tick affecting level geometry badly and has unoptimized AA, lighting and shadows effects.
Look into the low performance fix where you need to disable HID compliant devices, that could be lowering your framerate.
Yeah. It's usually listed under "Logitech wireless" or something.

steamcommunity.com/app/21090/discussions/0/864951657825089435/
forums.steampowered.com/forums/archive/index.php/t-1279444.html

... for two references, though ti won't let me post links...
. I ended up wondering why the heck I was getting 6 FPS - sure, my system's first gen Core i7, but still... Afterward, 300-some.

(And since links can vanish, quoting one of the others: :
[i]This is a known compatibility issue with the original F.E.A.R. engine and Logitech G series keyboards and mice, with an emphasis on the former. This is caused by the engine incorrectly overpolling the USB I/O in Windows. This is mainly apparent in all versions of Windows 7.

TO FIX

Simply go into the Start menu and right-click "Computer", choose "Manage".

From there, go to "Device Manager" and choose "Human Interface Devices".

To get the best performance, you are going to want to disable all "HID-Compliant Device", you should not need to disable ANYTHING else.[/i]
avatar
Ricochet: Yeah. It's usually listed under "Logitech wireless" or something.

steamcommunity.com/app/21090/discussions/0/864951657825089435/
forums.steampowered.com/forums/archive/index.php/t-1279444.html

... for two references, though ti won't let me post links...
. I ended up wondering why the heck I was getting 6 FPS - sure, my system's first gen Core i7, but still... Afterward, 300-some.

(And since links can vanish, quoting one of the others: :
[i]This is a known compatibility issue with the original F.E.A.R. engine and Logitech G series keyboards and mice, with an emphasis on the former. This is caused by the engine incorrectly overpolling the USB I/O in Windows. This is mainly apparent in all versions of Windows 7.

TO FIX

Simply go into the Start menu and right-click "Computer", choose "Manage".

From there, go to "Device Manager" and choose "Human Interface Devices".

To get the best performance, you are going to want to disable all "HID-Compliant Device", you should not need to disable ANYTHING else.[/i]
Unfortunately that would mean that I CANT use my keyboard or mouse so in otherwords I wasted my money on a broken version of the game since disabling my bluetooth devices is a no go.

Is there a workaround?
Post edited May 25, 2015 by xaneks
Some people have luck by disabling Logitech HID devices.

Some guy even wrote a script to disable the devices, enable any mice, run the game, and re-enable the devices.

Unfortunately, it did not work for me; but feel free to give it a try!

I've documented on my own blog the script and most links I could find about this issue: http://denilson.sa.nom.br/blog/2015-08-19/devcon-exe-and-fear-games/

There is also the article on the PC Gaming Wiki: http://pcgamingwiki.com/wiki/F.E.A.R.#FPS_problems
Post edited August 19, 2015 by denilsonsa
avatar
xaneks: I noticed that my frames are well below 30 frames per second on the copy of FEAR that I bought. I would love some help figuring out why I am getting less than playable FPS on this version when I can get above 60 FPS on a pirated or original disc copy of the game. Neeedless to say, even on my potato PC, I SHOULD be able to run it well above 60 frames per second.
A long shot but this MIGHT help: Have you tried tweaking the game's settings via your video card's control panel?