It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I checked the site and they say the retail version works ok with native dlls. Would this be valid for GoG version too? I don't want to miss this sale event but given that I still have about 5% of my GoG games still not running well under Linux, I'd like to know if I'm risking my money again.
I found this:

Seems good if you use PlayOnLinux (mentioned in comments below).

I haven't personally tried.
Post edited February 15, 2015 by hudfreegamer
I've been trying it and it just keeps crashing before even getting to the menu. I've only gotten to the menu once so far, and then couldn't start the campaign, telling me it disconnected from server (??). Installed and re-installed several times and it just won't work.

Edit: And shortly after writing this it starts working...

I had to install d3dx9_36 and set the dll override in wineconfig to native. However, there is no sound at all and the player arms and gun are semi-transparent.

Edit number 2: And now it's doing the same thing again. Don't bother.
Post edited February 16, 2015 by ModplanMan
Well, I just put my hard-earned money and got the game (I can always skip two lunch meals to make up for the lost money if it never works.)

The first time, the game won't even start. After trying with winedbg, it suddenly starts but without any graphics (sounds were working). Today, it starts with all the graphics and sound up to the menu screen, then it freezes except for the mouse movement. There is an error related to time out/blocked in thread.

At least there is hope. I'll try the dll override and such and see how it goes.

Update: Wow, It does work. I installed and overrid d3dx9_36.dll and everything works perfectly.

Thank you all for the solution.
Post edited February 19, 2015 by osce
Yeah I
can't get this thing working either and I hate using POL
Just to expand on what I wrote earlier for the issues I've had:

GOG installer seems to work OK, but cuts out near the end with an error, though the game seems like it's installed fully. The /nogui option wasn't much better for me, as after clicking next to start the installation, the install dialogue shows a blank area. Clicking next again seems like it causes the install to finish early after briefly showing a progress bar.

To make the game launch you have to install d3dx9_36 (e.g. using winetricks or playonlinux), however, this still leaves you without sound, which in turn causes other problems like the intro not working properly. Once you start the first level for example, your character exits the car before he's supposed to leaving you trapped outside of the playable map area behind an invisible wall.

To fix that, you can download the audio codec the game needs from here: (file should be wmfadist.exe).

Download from the link for the Windows 98/200/ME version. Don't run it, just extract l3codeca.acm and put a copy into F.E.A.R.'s main folder and also in your wineprefix Windows/system32 folder.

This fixes the sound issue (which also occurs under Windows for some) but that's as far as I can get. Occasionally the game will just crash on the main menu, refuse to start single player with a "disconnected from server" error or will hang on the first mission after getting out of the car. The game seems to keep corrupting its saves too which also causes it to hang on startup every so often. Deleting the folder where the game stores its saves and user config files will fix this, but leaves you with all progress lost.

Attempted this with multiple wine versions (1.7.34, 1.7.34 with gallium-nine, 1.6.2) and clean wineprefixes. I get a sense my errors are starting from the installer not quite working correctly, considering the lack of sound and lack of audio codecs the game requires.
Post edited February 20, 2015 by ModplanMan
The next Wine release (1.7.38) already contains the fix for the crashes/freezing issue.
There's no point to disable sound or install audio codec because the problem was in Wine's networking stack.

Installation is still buggy though.
The only remaining problem is the invisible weapon bug, but there's a patch for that.
I tested F.E.A.R. base game and all expansions are running perfectly except for the graphical glitch making your weapon and body transparant. (It will show your arms when you climb up/decend ladders though)

I installed the game with Play on Linux, used Wine version 1.7.38, installed d3dx9_36, set the dll files to override to native (Windows) With Wine 1.7.38 sound and audio are working flawlessly.

I also got the error that many GOG Windows installers get under Linux. You can ignore the error. Also you don't need to run the /nogui command when running the installer.

Thanks to everyone for helping me getting it set up! :D
F.E.A.R. kept freezing on me. I didn't realize my Wine installation was back on 1.6. Works great after installing the beta (1.7.38) and directx_Jun2010_redist.exe from FileHippo.
I could not get FEAR 1 and 2 working on Linux. Is there a proper installation to get it working?

I don't get it. On PlayOnLinux, there is a FEAR 1 and 2 installation available, but they're not for GoG. What the heck?!
low rated
Screw Linux and get yourself a copy of Windows.
I have not tried to install F.E.A.R. under Linux (I'm using Zorin).

With other games, I have installed them under WinXP, then they can be open and run in Linux, often with issues though.

I installed FEAR under XP and I have tried to open FEAR.exe in Linux. I can hear the intro movies and main menu and can see the mouse pointer, but the screen is black.

Edit: FYI, it is the retail version.
Post edited December 24, 2016 by BStone
BStone: I installed FEAR under XP and I have tried to open FEAR.exe in Linux. I can hear the intro movies and main menu and can see the mouse pointer, but the screen is black.
Believe it needs d3dx9.
BStone: I installed FEAR under XP and I have tried to open FEAR.exe in Linux. I can hear the intro movies and main menu and can see the mouse pointer, but the screen is black.
Gydion: Believe it needs d3dx9.
Holy smokes, it works!! :O Haha!

I thought I had d3dx9 installed.

Opened Winetricks.. Select the Default wineprefix>Install a Windows DLL or component. Found d3dx9. Now it works.

Haven't played enough to see if the arm and weapon are transparent or any bugs yet though.*



Sadly, the weaponry in invisible. And the quicksave takes 13 seconds instead of instantaneous. :(
May be unrelated, but GOG's Fallout 1 takes a long time to get past the very first intro screen. Coincidence?
Post edited December 24, 2016 by BStone
BStone: Sadly, the weaponry in invisible.
AppDB comments mentions the game uses DXTn textures. Not sure if that would make weapons invisible though. Be sure to have the needed library installed, libtxc-dxtn-s2tc0:i386 or similar. You also don't mention what Wine engine you are using, but I would suggest a current Staging one and enable CSMT.
Post edited December 25, 2016 by Gydion