It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

The game seems either to not draw some layers, or to draw them in the wrong order. I can see the characters and the hex outlines, but not the environment.

I tried a few different versions of Wine, using PlayOnLinux. No luck.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Try winetricks d3dx9_43.
No change. I guess I'll try installing Windows components haphazardly to see if something does the trick.

I appreciate the help, though!
Aaron_Blain: No change.
It works perfectly for me. The only other thing that may have an effect on my system is that I usually use wine-nine, in the form of gallium-nine-standalone on gentoo. Maybe you could try the full "winetricks d3dx9" suite. IN any case, I found the issue to be massive shader compile failures.

edit: I suppose I should also mention that I use wine 4 stable (currently 4.0.3). I think wine-nine is incompatible with wine-5. I could try without wine-nine and with different wine later today, but I won't reply about it until ljate tomorrow at earliest.

edit 2: works perfectly without wine-nine, in both wine-4.0.3 and wine-5.0.2, as long as you have the native d3dx9_43. I haven't tried it without d3dx9_43, and won't. The only other fix I've ever applied was d3dx9_30, which was necessary with an older version of Fantasy Wars, but I'm sure you're using the latest from gog, so that wouldn't do anything.

It's probably your video drivers. I'm using recent Mesa with Radeon, as I've been doing in various forms as long as I've owned Fantasy Wars.
Post edited November 29, 2020 by darktjm
Ok, none of that worked but I'll try messing with video drivers. It's Intel Integrated Graphics on an old Asus laptop. I'll do some research.

Thanks again for your help!