}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
So I bought Fallout 3, got it installed just fine, and tried to give it a whirl. But when I launched the game, my computer popped up with a warning saying that the game was incompatible with Windows 10. The warning also said to click there for more information, and upon clicking it just opened a webpage and downloaded the Games For Windows Live installer. It didn't install the program, mind you. It just downloaded the installer, leaving me to do the rest.

I ignored it and went into the game. And sure enough, after clicking "New Game," it crashed. Just like the Steam version was doing for me on my old computer before I put GFWL on it.

I'm not sure what's going on here, but I really don't want to have to install GFWL again. That program was a pain in the rear end, and since GOG has been saying that the game no longer needs GFWL to run then I really do NOT want to install it. I have no idea why my computer is insisting on needing GFWL.

Any ideas on how to fix this?
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
sciaenops22: Any ideas on how to fix this?
The crash doesn't occur every time (at least for me), though the version seems pretty unstable (I had five crashes until I finally made it past the 'shoot the radroach' portion of the prologue).

What fixed it for me was installing Tale of Two Wastelands for Fallout: New Vegas. That mod basically repackages the entirety of FO3 as mod for Fallout: New Vegas - meaning when you hit "New game" in New Vegas, it'll take you to Fallout 3 (you can travel to the Mojave via a train station in D.C. to access New Vegas).

Since I've done that, I haven't had a single crash, and I get to play FO3 with NV's improvements (iron sights, weapon mods, etc.) to boot. The only issue that's currently really grinding my gears is the frankly insane respawn rate - I can't round a corner without running into at least a duo of Enclave troops or five to six super mutants. Hell, I've loaded games in open world cells I'd just cleaned out, and am standing in fresh muties upon reload. No idea if that's intrinsic to FO3 (I remember being aggravated by the density of un-fun fights back then, but I do not remember if it was that bad), or a quirk from playing it that way.

In any case, I'll be trying a time scale mod to at least alleviate the respawn rate. I want to explore the wastelands without tripping over fresh spawns every ten meters.


edit: This obviously only works if you got both Fallouts, though you don't need the GOG version of both. I use Steam's NV and GOG's FO3.
Post edited June 05, 2017 by Mueslinator
avatar
sciaenops22: I ignored it and went into the game. And sure enough, after clicking "New Game," it crashed. Just like the Steam version was doing for me on my old computer before I put GFWL on it.

...

Any ideas on how to fix this?
The PC Gaming Wiki article mentions that Win 10 Anniversary Update can have this problem (maybe it also applies to the new Creator's Update too?). The article mentions using the graphics check bypass (which was created to allow Intel integrated graphics to work but maybe it helps with even newer machines and OSes too now?) to stop it from crashing. Here's the file: http://www.nexusmods.com/fallout3/mods/17209/?
So far for me the "Fallout 3 is incompatible with Windows 10" message does pop up but I can still play the game and it didn't give me the option to install GFWL which is a plus. Also so far the game is running well however I'm playing with a gamepad and sometimes the game keeps automatically swinging any melee weapon or shooting my gun without me doing anything. I gotta find that mod patch that fixes a lot of issues and mod it into the game.
avatar
sciaenops22: Any ideas on how to fix this?
It looks like Microsoft 'compatibility assistant' holds a record for Fallout 3 that suggests installing GWFL. It's safe to ignore, but as it's on the operating system side there is little we could do without breaking more things in the process.
avatar
sciaenops22: I ignored it and went into the game. And sure enough, after clicking "New Game," it crashed. Just like the Steam version was doing for me on my old computer before I put GFWL on it.

...

Any ideas on how to fix this?
avatar
korell: The PC Gaming Wiki article mentions that Win 10 Anniversary Update can have this problem (maybe it also applies to the new Creator's Update too?). The article mentions using the graphics check bypass (which was created to allow Intel integrated graphics to work but maybe it helps with even newer machines and OSes too now?) to stop it from crashing. Here's the file: http://www.nexusmods.com/fallout3/mods/17209/?
Ok, I forgot that I'd had that mod when I played this on Steam. Thanks for reminding me!

....unfortunately, now the game crashes on the very first load screen, but still, hey it was a solid try...
So this is only a problem for those using Windows 10 or is this a problem for those using Windows 7 too?
I downloaded F3 during the sale and haven't seen this at all. I have Game Mode disabled in W10. Maybe this? Have the Unofficial Patch and a few other mods.
I was having the same issue on "new game" with or without FOSE. What I did was use the mod: http://www.nexusmods.com/fallout3/mods/17209/? I only used the d3d9.dll not the fallout.ini file. It tricks fallout into thinking you have a old, but supported Nvidia card. The only thing is It will auto recommend to medium settings, or at least it did to me. So I copied that file and then overrode the recommendations in the launcher.
avatar
ashivor: I was having the same issue on "new game" with or without FOSE. What I did was use the mod: http://www.nexusmods.com/fallout3/mods/17209/? I only used the d3d9.dll not the fallout.ini file. It tricks fallout into thinking you have a old, but supported Nvidia card. The only thing is It will auto recommend to medium settings, or at least it did to me. So I copied that file and then overrode the recommendations in the launcher.
Bypassing the launcher when starting the game fixes the settings being overwritten each time you start. You can even edit the .INFO file Galaxy creates within the game directory to launch the game .EXE instead of the launcher .EXE, or maybe even the FOSE / NVSE .EXE so you can still use Galaxy and mods at the same time.


As for the respawnrate - I've been playing with Wanderer's Edition for years. It's so awesome. AP are stamina for sprint, there's a grenade hotkey, primary needs much like in Vegas and stuff to see to them, bullet time, and lots of new stuff and enemies. All modular, you can decide what you'd like to have and there are sliders to adjust the settings from the default realistic approach to super easy vanilla, or super hardcore look-at-me-and-you're-dead. It adds refreshingly new gameplay elements and approaches to situations, but all within the "I should be able to do that" realm. Highly recommended.

Fallout: Wanderer's Edition [& other mods]
https://www.youtube.com/watch?v=a7b0mjp1wRA
avatar
sciaenops22: Any ideas on how to fix this?
avatar
Thiev: It looks like Microsoft 'compatibility assistant' holds a record for Fallout 3 that suggests installing GWFL. It's safe to ignore, but as it's on the operating system side there is little we could do without breaking more things in the process.
Sorry to necro the thread but i've just gone to win 10, (the game ran fine on vista x64 and (8.1 pro x64(which i had for about 3 weeks)) then i got the free upgrade to 10 in january and decided to try FO3 the other day and i got sent to the gfwl download page, (it wasn't auto, it asked me to save file, which i canceled), i then clicked play on the launcher and the screen went black with the egg timer for a few seconds and then got the FO3 has stopped working and must close message

i tried check install / verify and got a small (1mb) download, but the problem still exists, are you working on a fix ?