It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

After I've installed tactics (worked fine) and i try to run the exe i get an error:
c:devphoenixdisplaydirectx7dd7_display.cpp(715): **fatal error**: Could not create primary and back surfaces
no change if I use compatability mode for the exe. Worth noticing is that directory on c: doesn't exist (and i installed tactics on another partition as well).
Any ideas?
No posts in this topic were marked as the solution yet. If you can help, add your reply
I've got the same problem, the game did'nt even start after it was freshly installed. Same errormessage...
Perhabs its something about my laptop graficscard, because on my desktop pc its running without any problems.
Someone any ideas? Newest drivers are installed....
Post edited January 15, 2009 by TeppichPilot
What kind of hardware are you guys running?
Have you also tried running the game in admin mode (if on Vista)?
Post edited January 15, 2009 by JudasIscariot
could you tell us a ittle more about your setup?
in the meantime have you tried sending your error messages to tech support?
Though you "freshly installed" was it from the same download?
Well it's saying something about directx... Yeah, what video card do you have?
And.. Cpp?
Post edited January 15, 2009 by Azarr
Also, the drivers for the video card, they aren't beta I hope?
Try turning down the graphics acceleration by a notch and see if that works. Many older games don't seem to like full acceleration (or to be more accurate, many cheaper video chips don't do full acceleration properly and older games are less tolerant of stuff ups)
Display properties - Settings tab - Advanced button - Troubleshoot tab (I think thats right, I'm not near xp at the moment)
Failing that, reinstalling direct x might help.
Have you tried making that directory on C? Probably won't do anything but at least you'd get rid of the "but it's not even there!!" confusion.
Post edited January 15, 2009 by Aliasalpha
My System:
P4 2,4 GHz
512 MB Ram
ATI Radeon 9000 Mobility (newest Omega Drivers, doesn't work with the original drivers either)
Windows XP Prof. (newest SP and Updates)
I donwloaded the gamepackages twice, none of them worked so far....
I'll try some screwing around with the grafics and direct x properties when I'm back from work. (actually its 8:27 in the morning right now :) )
Thanks for your help!!
Post edited January 16, 2009 by TeppichPilot
So, wether the directx part nor the graficsdrivers part worked, any idead left? :(
Well I went to the NMA forums after googling that error message and I found something that may help you .....or not But it's worth a try regardless...
Open up your start menu
type in :
"run C:\program files\gog\FalloutTactics\bos.exe -7" in the Run line
(The C: directory is just an example - just find the exact path of your Fallout Tactics installation)
The -7 forces it to use DirectX 7 instead of the newer one.
Make sure antivirus software is off.
Another question for you. When you install the game, what install option do you use?? Try using the Full install instead of Minimum or anything like that.
Try using these other commands as well:
-m no music
-s no sound
-3 use direct x 3
-7 use direct x 7
-g use windows gdi
Post edited January 16, 2009 by JudasIscariot
FWIW, I'm running Windows 8.x x64 and Fallout Tactics works for me using the -3 switch to select DirectX 3. It prompts you about installing DirectPlay when you try to run it, but I told it to ignore the issue and noticed no ill effects.
Anybody ever figured out what's wrong?
i went into the folder and right clicked BOS(the run program), properties, and changed it to run on 16-bit color...i also have it run on windows me settings but i dont know if that was a factor or not, because it only worked once i changed the 16 bit color. I downloaded the 3 pack from steam, not sure if the file would be under a different name if you do it another way