It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

After updating to Mac OS 10.14.4, I decided to download the gog version of Fallout 2 and see if I could mod it. I've had... limited success. I'll list the step-by-step procedures that I have done in order to get this done incase anyone has any suggestions regarding how we may be able to get this fixed.

FIRST STAGE: Getting the game ready

1. Install 'Fallout 2' in the HD Application folder (Not my user folder)

2. Allow your 'Security & Privacy' setting in the System Preferences to run the Application.

3. Run the application. This part is CRUCIAL because before the game starts, Wineskin will ask you to download and install an update. This is a very quick process that doesn't prevent the launch of the game once it's installed. This is essential because if you don't install that update, you won't be able to open later on.

4. Right Click the application to 'Show Package Contents'.

5. When the new folder is up, navigate via 'Contents > Resources > Game' and you will see two items. '!_delete_me' and 'Fallout'.

6. Right click the 'Fallout' to 'Show Package Contents' again. Last time, I promise.

7. Here you will see four items. 'Contents', 'drive_c', 'Extras' and the '' application.

8. Open the, click the 'Advanced' button, click on the 'Tools' tab at the top, and in the 'Wine Tools' column, click on the 'Registry Editor (regedit)' button. This will bring up a new 'Very Windows' looking window.

9. Navigate through this path and delete the second item in the 'Layers' folder that lists an item that under the data column as '256COLORS'

HKEY_LOCAL_MACHINE > Software > Microsoft > Windows NT > CurrentVersion > AppCompatFlags > Layers

HKEY_CURRENT_USER > Software > Microsoft > Windows NT > CurrentVersion > AppCompatFlags > Layers

10. Game Modification complete! Now onto the Restoration Project.


1. Download the 'Windows Installer' for the 'Fallout 2 Restoration Project 2.3.3'.

2. Using Wine Stable, run the installer.

3. When it asks you to find the directory where the game is, it is NOT asking you for the game that's located in your Applications folder, but it is inside there. This is what my path looks like with the game in the HD's application folder.

Z:\Applications\Fallout\Contents\Resources\game\Fallout\Contents\Resources\drive_c\Program Files\\Fallout 2

WARNING: This software insists that if you're running a Mac that you select the 'Legacy' version of the Higher Resolution settings. I've tried this and it winds up giving my copy of Fallout 2 issues on start up. Selecting the full recommended one seems to do the trick. However, there are 'issues' with the resolution that I'll get into in a moment.

4. Once installed, run Fallout 2.

And that should be it! You should be able to play the full Restored Project without any issues.

THIRD STAGE: Increased Resolution

However, if you're planning on increasing the resolution of the game, you WILL run into game breaking issues. When your on Fallout 2's in-game menu and you click on options, you'll see an added selection that takes you to a 'screen resolution' page. If you did everything right up to this point, the only option you will see is a 640x480 option. Now I've tampered with the resolution via the Wineskin app, the setting in the High Resolution exe file and it's a mess.

For example,

WARNING! Following these steps will prevent your game from launching

When you open the '', select 'Screen Options' and change the screen settings from anything but 640x480, the game will launch fine, but when you go to the added 'Screen Resolution' options menu, things will start to look weird. The screen will actually shift from one size to another until it finally settles down on a 640x480 look. But since the resolution was increased via, you now have options to adjust the resolution! Now when you select any of the resolution options given to you, it will change the resolution and still run the game fine. However, the moment you quit the game, you WILL NOT BE ABLE TO OPEN IT AGAIN. You'll get warnings saying that the game cannot run at the resolution you set and will quit. I've tried everything to change it back to 640x480, or make more adjustments to try and get it to work, nothing seems to take.

So that's where I'm at in trying to get Fallout 2 'Restoration Project' to work on a higher resolution. If anyone has any suggestions on how I can tackle this further, let me know!
Post edited April 21, 2019 by Jeyl
No posts in this topic were marked as the solution yet. If you can help, add your reply