It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I am using Killap's Restoration Project, and when ever i am in combat, during my enemies turns, windows will say the game is not responding, showing the loading mouse icon, and the screen going gray until their turn is over, i can keep playing the game, i just can't see what happened while it wasn't my turn, which is really frustrating, because it makes combat alot harder and makes things like boss fights really uncinematic, for some reason it only happens in combat and i've looked up every fix and i don't know what to do. i've tried changing it from direct x to direct draw, changing the resolution, uninstalling and reinstalling, putting it on a smaller monitor, i don't know what to do.i can't tamper with the ddraw.dll or apparently the restoration project won't work.this sucks because about six monthes ago i wasn't having any problems with the game but i had to install windows 8 instead of keeping windows 7 and now everythings shitty.

my specs,

System Information
------------------
Time of this report: 4/2/2014, 19:11:18
Machine name: A-KOO-CHEE-MOYA
Operating System: Windows 8.1 64-bit (6.3, Build 9600) (9600.winblue_gdr.131030-1505)
Language: English (Regional Setting: English)
System Manufacturer: MSI
System Model: MS-7642
BIOS: Default System BIOS
Processor: AMD Phenom(tm) II X6 1055T Processor (6 CPUs), ~2.8GHz
Memory: 8192MB RAM
Available OS Memory: 8192MB RAM
Page File: 2846MB used, 13537MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.03.9600.16384 64bit Unicode

--------------
Display Devices
---------------
Card name: NVIDIA GeForce GTX 460
Manufacturer: NVIDIA
Chip type: GeForce GTX 460
DAC type: Integrated RAMDAC
Device Type: Full Device
Device Key: Enum\PCI\VEN_10DE&DEV_0E22&SUBSYS_13733842&REV_A1
Display Memory: 4043 MB
Dedicated Memory: 971 MB
Shared Memory: 3071 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: Panasonic-TV
Monitor Id: MEIA0AD
Native Mode: 1920 x 1080(p) (60.000Hz)
Output Type: HDMI
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver File Version: 9.18.0013.3165 (English)
Driver Version: 9.18.13.3165
DDI Version: 11
Feature Levels: 11.0,10.1,10.0,9.3,9.2,9.1
Driver Model: WDDM 1.3
Graphics Preemption: DMA
Compute Preemption: DMA
Miracast: Not Supported
Hybrid Graphics GPU: Not Supported
Power P-states: Not Supported
Driver Attributes: Final Retail
Driver Date/Size: 10/27/2013 10:12:42, 18199872 bytes
WHQL Logo'd: Yes
WHQL Date Stamp:
Device Identifier: {D7B71E3E-4D62-11CF-AF57-7E331CC2C435}
Vendor ID: 0x10DE
Device ID: 0x0E22
SubSys ID: 0x13733842
Revision ID: 0x00A1
Driver Strong Name: oem5.inf:0f066de3a63b2138:Section032:9.18.13.3165:pci\ven_10de&dev_0e22
Rank Of Driver: 00DA2001
Video Accel: ModeMPEG2_A ModeMPEG2_C ModeVC1_C ModeWMV9_C
D3D9 Overlay: Supported
DXVA-HD: Supported
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled

Card name: NVIDIA GeForce GTX 460
Manufacturer: NVIDIA
Chip type: GeForce GTX 460
DAC type: Integrated RAMDAC
Device Type: Full Device
Device Key: Enum\PCI\VEN_10DE&DEV_0E22&SUBSYS_13733842&REV_A1
Display Memory: 4043 MB
Dedicated Memory: 971 MB
Shared Memory: 3071 MB
Current Mode: 1920 x 1080 (32 bit) (59Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: W2243
Monitor Id: GSM56FF
Native Mode: 1920 x 1080(p) (59.934Hz)
Output Type: DVI
Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver File Version: 9.18.0013.3165 (English)
Driver Version: 9.18.13.3165
DDI Version: 11
Feature Levels: 11.0,10.1,10.0,9.3,9.2,9.1
Driver Model: WDDM 1.3
Graphics Preemption: DMA
Compute Preemption: DMA
Miracast: Not Supported
Hybrid Graphics GPU: Not Supported
Power P-states: Not Supported
Driver Attributes: Final Retail
Driver Date/Size: 10/27/2013 10:12:42, 18199872 bytes
WHQL Logo'd: Yes
WHQL Date Stamp:
Device Identifier: {D7B71E3E-4D62-11CF-AF57-7E331CC2C435}
Vendor ID: 0x10DE
Device ID: 0x0E22
SubSys ID: 0x13733842
Revision ID: 0x00A1
Video Accel: ModeMPEG2_A ModeMPEG2_C ModeVC1_C ModeWMV9_C
D3D9 Overlay: Supported
DXVA-HD: Supported
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled

please help me
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
dogchrist: ...this sucks because about six monthes ago i wasn't having any problems with the game but i had to install windows 8 instead of keeping windows 7 and now everythings shitty.
...
Definitely try to run it in Compatibility Mode for Windows XP SP3 (right-click the game's shortcut => Properties => Compatibility tab). It's also worth trying to run it as Administrator, if Compatibility mode alone doesn't work.

In addition you can try these settings with \Fallout 2\FALLOUT2.EXE and start the game with this file instead of using the game's shortcut, which starts the game via the GOGLauncher.exe.
if it makes any difference i'm playing in windowed mode.

i also only use the .exe and i always play it in administrater mode, and compatibility mode doesn't work for some reason, i put it in the correct colour scheme and resolution and it asks me to do it again

it doesn't make any sense that my computer should lag during combat for a turn based isometric rpg from the nineties.
Attachments:
Post edited April 03, 2014 by dogchrist
avatar
dogchrist: if it makes any difference i'm playing in windowed mode.

i also only use the .exe and i always play it in administrater mode, and compatibility mode doesn't work for some reason, i put it in the correct colour scheme and resolution and it asks me to do it again

it doesn't make any sense that my computer should lag during combat for a turn based isometric rpg from the nineties.
Obvious question: is the problem only in windowed mode, or does fullscreen mode give you the same issue?

Could be something screwy in f2_res.ini and/or ddraw.ini - sometimes they don't get set right, and I don't know how much testing was done with Win8. So the second thing that springs to mind that can normally do this (on other Windows versions anyway) is the settings in [MAIN] in f2_res.ini and the [Graphics] section in ddraw.ini. A number of these require manual editing of the config file, might be worth a shot playing around with these settings.

Also ddraw.ini has a SpeedMod section - but if that were screwy you'd probably experience issues throughout the whole game and not just the combats.

Note that by default these files are located in your user directory on Vista and above, NOT the game directory. The game SHOULD figure out where they are, but if you run it as Admin it might be using different files (e.g. Admin instead of your user dir?).

BTW although compatability mode is recommended, I definitely would NOT run it in 640x480 or 256 colour mode as the RP uses higher res/colours than this.


Finally, a really weird question: Had you previously installed Fallout2 before? When you look at the directory containing Fallout2, is that the only Fallout2 directory in there? It sounds screwed up but ages ago I had a "phantom" freaky Fallout2 directory with the EXACT SAME name somehow existing even though I had deleted it previously. It came up as a "hidden" directory and was empty - it was freaky because this shouldn't have been possible! You might have to set your Explorer window to show hidden files before you find it, if that is the case... Yes it's a long shot but it happened to me and confused the crap out of me.
so i installed virtualbox, and installed windows xp on that, and now on that, it runs smoothly except the mouse is buggy, i had to go into the ddraw.dll and for some reason make the mouse sensitivity 3 when it was set to 100. even now it still a bit screwed but its the best i can get it, it doesn't lag in combat any more but its still interesting to figure out how i could run it just in windows 8 because that would be less ackward. like i said though, compatibility mode won't work for some reason and i don't understand what i would screw around with in ddraw.dll and i'm not going to just randomly change stuff.

interesting to note, six monthes ago when this worked, i was using windows seven, and i was able to install fallout 2 with relative ease. so it really is something about windows eight it seems.
Post edited April 04, 2014 by dogchrist
avatar
dogchrist: so i installed virtualbox, and installed windows xp on that, and now on that, it runs smoothly except the mouse is buggy, i had to go into the ddraw.dll and for some reason make the mouse sensitivity 3 when it was set to 100. even now it still a bit screwed but its the best i can get it, it doesn't lag in combat any more but its still interesting to figure out how i could run it just in windows 8 because that would be less ackward. like i said though, compatibility mode won't work for some reason and i don't understand what i would screw around with in ddraw.dll and i'm not going to just randomly change stuff.

interesting to note, six monthes ago when this worked, i was using windows seven, and i was able to install fallout 2 with relative ease. so it really is something about windows eight it seems.
It wouldn't surprise me if it's something about Windows 8 - but it also wouldn't surprise me if there's some fix somewhere for it (which is either very simple or ridiculously obscure).

Have you tried checking the NoMutantsAllowed boards? The dev of the RP is still active there, and it's typically a good place to find out how to get around issues with RP (or other mods like the High Res Patch). Here's the board for the RP, but might be worth checking the one for the High Resolution patch as well: http://www.nma-fallout.com/showthread.php?201223-Fallout-2-Restoration-Project-2-3-2-%28Unofficial-Expansion%29

Also this might help you though I don't think it's Win8 specific but might be worth a shot: http://www.gog.com/forum/fallout_series/fallout_2_is_slowlags
Post edited April 04, 2014 by squid830
i read through the thread and like you posted in it, because i installed the latest version of fallout restoration project all the dll's (i checked) are the way they are supposed to be. on a side note i can't use direct x 9 in xp and have to use directdraw 7. i wish i could find a fix for teh mouse lag issue, its still laborious, i can't get it accurate and fast. it worked perfectly on windows 8 but for some reason its like windows 8 thinks that the combat animations are like a derezed program chugging and trying to think and its like setting up a paperparition for it like its the victorian era and its a lady dressing, so i don't get to see anything and i don't know how to move further.
avatar
dogchrist: ... side note i can't use direct x 9 in xp and have to use directdraw 7. i wish i could find a fix for teh mouse lag issue, ...
Try installing the VirtualBox Guest Additions for Windows XP, if you haven't done so, already.
already did lol

still mouse issues, but i ve gotten it to a manageable extent, some window scrolling issues as well cuz i'm playing in windowed mode
Post edited April 05, 2014 by dogchrist
So, I hadn't seen the answer to this on the forums anywhere. Thought i would just toss it out there.

Open -- f2_res.ini in the Fallout 2 folder.

Under [INPUT]

Change from 0 to 1 EXTRA_WIN_MSG_CHECKS=0 -> EXTRA_WIN_MSG_CHECKS=1



Also, ALT_MOUSE_INPUT=1 will prolly fix your mouse isses too.
This prolly won't help, but I'll post it just for the sake of not overlooking the obvious: you haven't been trying to save the game during combat, have you? If so, don't do that. Not a good idea.
avatar
AngryAmadeus: So, I hadn't seen the answer to this on the forums anywhere. Thought i would just toss it out there.

Open -- f2_res.ini in the Fallout 2 folder.

Under [INPUT]

Change from 0 to 1 EXTRA_WIN_MSG_CHECKS=0 -> EXTRA_WIN_MSG_CHECKS=1

Also, ALT_MOUSE_INPUT=1 will prolly fix your mouse isses too.
Thanks AngryAmadeus for putting me on the right path!

One thing that may differ is the location of "f2_res.ini" file. Changing values in "f2_res.ini" found in the fallout2 install folder did not help. Found instead (on my windows 10 install) that the game made a copy of the settings here:
C:\Users\<username>\AppData\Roaming\Fallout2\fb19dfba45f11cc8895f1e3fa3d4924d\f2_res.ini"

So you may need to navigate to your "..\AppData\Roaming\Fallout2\" folder and open whatever folder is there to locate the "f2_res.ini" file and make changes there in order to have them work.

Alternatively, use the "f2_res_Config.exe" program in the fallout2 install folder and then click the "Manually Edit Config" button to have it open the ini file in a text editor and then change and save the values there.