It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Did I mess up or does NVSE ver. 5.1 not support the GOG version of the game's EXE? I've tried to launch it (both directly through the NVSE EXE and GOG Galaxy using the file renaming trick), but all I got was "please update to the latest version" message.
The GOG forums suggest that earlier versions of NVSE (5.0) should work just fine, but I'd rather avoid having to trouble-shoot all the other mods/fixes I want to install (http://puu.sh/CQvQv/aa594ac86a.png) because I've used an older NVSE release.

Also, yes, I'm completely new to New Vegas/Gamebryo/Creation Engine modding and things are pretty confusing. I just want to fix some bugs, iron out some kinks and make the game more stable. My setup uses Win7 64-bit and 8 GB of RAM.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Well I juist purchased GOG FO: New Vegas and then installed the lastest NVSE and worked fine.

You only need the:

nve_1_4_.dll
nvse_1_4ng.dll
nvse_editor_1_4_.dll
nvse_loader.exe

Create short cut and run the new .exe.

Then installed MOD Org 2. Works good so far.

On to modding.
I think I've found out what my issue was (and that I'm dumb, but it's nothing new). I've needlessly installed the 4GB Patch - the Nexus page claims it supports the GOG version, but after some more digging it turns out the GOG ver. is already tweaked to support more than 3 GB of RAM, rendering the patch useless.
It seems that installing the patch anyway will "break" your EXE file, which in turn breaks NVSE. Makes sense to me.

A clean install of NV and reimplementing NVSE seemingly fixed the issue for me - the game boots up without a hitch when using nvse_loader.exe. We'll see if slapping more mods on top of it breaks anything again.
Glad you figured it out. Happy modding.